AppImage Doesn't run

I downloaded the BitWarden AppImage file to run on CentOS, and it doesn’t run. I get this when I try to execute it:

$ ./Bitwarden-1.27.1-x86_64.AppImage
[10610:0709/] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I’m aborting now. You need to make sure that /tmp/.mount_Bitward0u9Vm/chrome-sandbox is owned by root and has mode 4755.
Trace/breakpoint trap (core dumped)

I can create that directory and set the file permissions as noted, but I assume it’s trying to mount something there. A quick search on AppImage files says this sort of error means the app was not developed properly and I need to contact the developer. I have permissions opened up on the AppImage file, and I tried running with and without sudo. With sudo, it tells me I need to specify --no-sandbox.

I’ve never used an AppImage file before. My understanding is that “it just runs”, but it seems to be assuming that something was set up on my computer already, and I don’t see any documentation about dependencies or instructions for setup before I run the app that was provided.

Did you try searching on the CentOS forum?

Thanks for replying. I did see that link, but the solution there is to use a different AppImage for that particular app.

It works fine on my Ubuntu system at home. The problem was on my office computer, running CentOS 7. For some reason, the error I reported in my OP stopped happening, but now it fails because it’s looking for an older version of libstdc++ than I have installed. So I guess the app doesn’t support CentOS 7.

I’ll just use the browser extension. I wanted to install the desktop app just to give me an extra option, but I guess I don’t really need to do that.