Android app log in fail

Just opened an account and am getting started. Downloaded the Android app and immediately could not log in. Phone is a Samsung Galaxy A20 with Android version 11. I enter my user/password info and after a minute or so get “An error has occurred. Exception message: The operation was canceled.” Attempted multiple times. User/password correct. Rebooted phone. Uninstalled/reinstalled app. No change. Wi-fi is strong. Cell signal is weak today due to weather in the area. What am I missing?

Hi @Evan_Davis - welcome!

Have you tried logging in to the web vault at to verify that your login email and password are correct?

I did that several times to make sure.

I would try uninstalling Bitwarden from your phone, restart the phone, then install BW again. Something may have been corrupted.

If that doesn’t work, I would get in touch with the Bitwarden CS team to see if they can help - that’s very unexpected behaviour. Hope you get it fixed easily!

1 Like

It seems to be happening to a bunch of people ive reached out to bitwarden of course no reply.

Why do you say “of course, no reply”? From what I have seen reported on the forum here, the vast majority of people are very happy with the response times from the Bitwarden staff. If you don’t mind me asking, how long have you been waiting?

I read it more as, “I’ve reached out to Bitwarden of course. No reply (as yet)”.

Ahhh, the power of punctuation!


1 Like

I appear to have the same android logon failure, my Samsung Galaxy Note 9 stopped updating Bitwarden a while ago, now I can’t log on to my account, I get the spinning wheel when I enter my credentials, then an error message pops up, no message about 2FA or authenticator options?

The account works fine on Win10, Macbook Pro, iPhone & linux. I’ve reinstalled the App several times & been in touch with support - any ideas?

Here is the recent response I got from bitwarden tech support. Unfortunately the suggestions did not resolve my problem but may help someone else.

“When you get that error, do you have an active and working Wi-Fi connection? You need either a cellular or wi-fi connection to connect to the app but it does not have to be cellular specifically. You could reboot your modem / router then test again to see if that provides any relief.”

“Another question, did you have an active VPN connection or any other special network configurations when attempting to connect? Sometimes those can interference and the login to cancel.”

“One additional thought, is your time and date set to set automatically or set manually on your device? Date and time being off can also sometimes cause conflict in the login process. I would suggest switching it to set automatically, at least temporarily to test.”

1 Like

Yes I have date/time set to automatic (which is provided by the network) & I don’t use VPN, I’ve also turned off wifi & tried using a direct connection by 4G - no difference here, logging in still has a spinning wheel then the error message - An error has occured, Exception message: The operation was canceled (should really read cancelled - but I’m an awful speller too). All of my other devices work fine with Bitwarden?

I just had this issue. Maybe try disabling IPv6 on your router, that worked for me

1 Like

Thanks for the suggestion. My phone won’t let me disable. Found this quote on one website: “Unfortunately, it is not possible to disable IPv6 through Wi-Fi network settings on an Android device.” On my router settings under LAN/DHCPv6, “Enable DHCP-PD” is already disabled. I’m not a network engineer but I’m guessing that means IPv6 is not on.

I mostly use Bitwarden @ home via wifi, I originally tried turning off wifi on my Android phone to eliminate my router & attempted to logon to Bitwarden via my very poor 4G connection, that failed.

I tried again today via a much better 4G connection & that worked.

An update made to support - Bitwarden for Android only appears to work for me if I reinstall it over a good 4G network. Your app doesn’t update my account, or allow for a reinstall over wifi - it’s been like that for ages. I only noticed after looking for updates that I had made weeks ago. I expect the majority of your Android users haven’t yet noticed that their updates are missing.

Well there it is! That worked for me too. Turned off wi-fi on my phone and the login was successful. I guess i can live with that, although it would be nice to know if they are working on a fix. Thanks for the tip!

I have had no issues whatsoever with logging in to BW or updating the client apps on my Android devices. And although there is some activity on this thread by a number of people, I suspect that this problem is a relatively isolated issue - not widespread.

I wonder if this issues is more related to your ISP than the BW app? To test this, you could try updating BW on another wifi connection when you are not home - if it works, it must have something to do with your ISP or your router configuration relative to the device. If so, I would check your DNS settings on the device and on your router, as well as the ipV6 settings. Those seem to be common culprits, and not just for BW.

Thanks David, I’m not easily able to try another persons wifi system as I live in a remote rural location with poor mobile services - my other systems all work fine with Bitwarden (Macbook Pro, iPad, Win10 PC, iPad 13 & Linux) all over my Sky fibre wifi. I shouldn’t reallly need to bother my neighbours to use their wifi should I !

As mentioned, I wasn’t aware that my Android mobile wasn’t updating the entries that I’d made on my Macbook - it used to. When I tried reinstalling Bitwarden on the Android over wifi I found out that I was no longer able to use Bitwarden Android @all locally or complete a reinstall over wifi.

So as far as I’m concerned the current Bitwarden on Android doesn’t work! - unless of course I go through the annoying process of hunting down a decent 4G signal when away from home & then performing a re-install in my car.

Like other users who bought Bitwarden primarily for Android use I am a reconsidering my options.

I’m an Android user and sync BW vault entries across my phone and several Windows and Linux systems. I’ve never come across this issue, so it does sound like something particular that’s causing it rather than a fundamental problem with BW.

1 Like

Ok I’ve just run into this exact issue now, on 2 different phones.
Pixel 4xl and Samsung A40.

Does like say let login on cellular but then as soon as I need a WiFi connection and then i go back into bitwarden same issue again on both phones.

This is also on different WiFi networks also.

This will be a real pain if it is not fixed asap