Android app log in fail

Even downgrading to 2.14.3 the same issue persists, wounder if it is server side related then

I think if it were a server-side issue, we would see a lot more reports of issues.

Do you run a VPN on those devices? They will sometimes mess up your network settings on Wifi, especially DNS resolution. I would have a look. I would also try disabling ipV6 on your router to see if that helps.

2 Likes

As our esteemed colleague @dh024 mentioned above, if this was a BW/server issue,the board would be blowing up.

When there are isolated problems (and this applies to me as well, as I love tinkering with my phone) it’s usually a user-side issue. App conflict, settings issue, etc.

See if you can rollback some of your app installations / sys tweaks, and then restart the phone and retry. Also delete and reinstall of BW wouldn’t hurt as well.

1 Like

An update: I’ve just purchased a months VPN subscription from Mullvad & I can now use Bitwarden on all of my devices via VPN over wifi & that’s including my Android mobile.
Hooray - problem resolved for me.

2 Likes

I am facing a similar issue. I tried to setup BW on a second android phone only on Wifi and it keeps erroring out on the login (Exception message: The operation was cancelled) . I am not using a VPN. I tried with 3 different Wifi connections but it doesn’t seem to work on any.

I just resolved this problem for me. The same solution might work for you. Being a retired network admin, I wondered what might get in the way of login and my first try was DNS. I logged into my cable modem/router and over rode the ISP’s DNS servers. I chose to use Google and CloudFlare. Bingo! BW logged right in and loaded the latest vault. We have Xfinity.

It’s very strange. It does not work from a Huawei P40 Pro, Android device, Bitwarden downloaded from Fdroid. Disabling WiFi (with IPv6 active) solves the issue, it works perfectly on mobile data. It’s the only app that does this.
Now the strange thing is that in the same WiFi network, Bitwarden works from all the other devices it is installed on, a Windows 11 notebook, an iPhone and including an Android tablet with the app installed from Google Play store that has no mobile data active on it, only WiFi.

Did you try disabling ipv6 on your home router, as recommended above? Android is funny about ipv6 and always seems to want to use it, but some home ISPs seem to have trouble with routing it, apparently.

It was easier to disable Wi-Fi on the mobile phone than to try to remember my router password that is not saved in Bitwarden. :slight_smile:
But as I said, Bitwarden works from all other devices in the same Wi-Fi network so it’s not related just to ipv6. It must be something the device is doing differently than the others.

Yes, android and ipv6 don’t seem to play well together for some reason. And in Android, there is no option to disable IPv6 on the device, hence my suggestion.

I couldn’t log in on android and I went to the bitwarden app settings in the storage settings and cleared the cache for the app and it worked. For anybody not used to going into these settings open the android settings then all apps and tap on bitwarden then tap on storage. Hopefully this helps somebody else.

I could not log on ,unspecified error, turned on vpn and success