"An unexpected error has occured."

I am also affected by this scary issue.

The same problem occurs :

  • On a fresh OSX Chrome profile (so no plugin or nothing) when trying to log in on the website.
  • Same problem on 2 differents macbooks
  • Same problem on Safari
  • Same problem with browser extension.

It all began when this hCaptcha appeared (never seen that before)

No, the captcha form is firs submitted and the message pop up when you click on “login”

My devices (Latest Macbook Pro) are brand new. Same problem. This is not related.

This happened to me this morning. I’m not happy that something Bitwarden introduced prevented me accessing MY VAULT.

Fortunately, without re-starting my computer or installing anything, it then started working after I had logged in here. It didn’t work with the web vault or Chrome add-on. Didn’t try anything else.

I have been away from this forum since the summer, as I have been busy on other things. Used to love chatting here, but no-longer have the time, sadly.

Please pull your socks up Bitwarden. My data is backed up, but having something which blocks me accessing MY VAULT is not a good development. Captchas are rubbish for number of reasons, I’m very surprised that Bitwarden has followed that deadbeat idea.

Hi @Davidz this error message is currently the result of an incorrect username, this issue is being tracked on Github here.

My problem was solved. I had a typo when originally creating my account, as a result an error occurred evertime I logged in using, what I thought, were correct credentials. Take the advice of @bw-admin and double check your account.

1 Like

I am having the same problem.

“An error has occurred. Could not send login notification email. Please contact your administrator.”

  1. I logged in like normal–my password was copied and then pasted to login to my Bitwarden.
  2. None of my passwords were showing and Bitwarden had a notification saying I needed to update my encryption and to enter my master pass to update (I performed this same thing a few months ago with no issue)
  3. I then clicked update and was logged out.
  4. Now I cannot login with the quoted error above.

(This error is produced from clicking ‘LOGIN’)

Hi Jeremy (@King) - welcome!

Actually, this sounds like a much different issue. Can you send more details on what kind of devices you are using (and OS versions), which Bitwarden app/client you are using when the error is generated, and whether you are using Bitwarden services on the cloud or if you are self-hosting your vault on your own server?

1 Like

My laptop OS

PRETTY_NAME=“Kali GNU/Linux Rolling”
NAME=“Kali GNU/Linux”

Bitwarden Version 2.25.1

The error is generated upon clicking ‘LOG IN’ after entering proper credentials.

(Important to note: The error is not generated when purposely entering false credentials. Entering false credentials produces the expected wrong user/pass error.)

I am self-hosting Bitwarden on my own dedicated server protected by Cloudflare Pro.

My server’s OS

AME=“CentOS Stream”
ID_LIKE=“rhel fedora”
PRETTY_NAME=“CentOS Stream 8”

OK, thanks. Are you running the official Bitwarden server software? Or is this something else, like Vaultwarden or bitwarden_rs? Based on your error message, I suspect the latter - is that correct?

© 2022, Bitwarden Inc. (Powered by Vaultwarden)
Version 2.25.1

Perhaps the issue is something like this? can't login to admin panel after update · Issue #425 · dani-garcia/vaultwarden · GitHub

Vaultwarden is not a product of the Bitwarden group. Your problem sounds like it server-side, so you should really approach their support for help.

I was able to login to my admin page and produce a diagnostic text

Your environment (Generated via diagnostics page)

  • Vaultwarden version: v1.24.0
  • Web-vault version: v2.25.1
  • Running within Docker: true (Base: Debian)
  • Environment settings overridden: true
  • Uses a reverse proxy: true
  • IP Header check: true (X-Real-IP)
  • Internet access: true
  • Internet access via a proxy: false
  • DNS Check: true
  • Time Check: true
  • Domain Configuration Check: false
  • HTTPS Check: true
  • Database type: SQLite
  • Database version: 3.35.4
  • Clients used:
  • Reverse proxy and version:
  • Other relevant information:

Config (Generated via diagnostics page)

Show Running Config

Environment settings which are overridden: DOMAIN, SIGNUPS_ALLOWED, ADMIN_TOKEN

  "_duo_akey": null,
  "_enable_duo": false,
  "_enable_email_2fa": true,
  "_enable_smtp": true,
  "_enable_yubico": true,
  "_ip_header_enabled": true,
  "admin_ratelimit_max_burst": 3,
  "admin_ratelimit_seconds": 300,
  "admin_token": "***",
  "allowed_iframe_ancestors": "",
  "attachments_folder": "data/attachments",
  "authenticator_disable_time_drift": false,
  "data_folder": "data",
  "database_max_conns": 10,
  "database_url": "****/**.*******",
  "db_connection_retries": 15,
  "disable_2fa_remember": false,
  "disable_admin_token": false,
  "disable_icon_download": false,
  "domain": "*****://*********.******.***.******",
  "domain_origin": "*****://*********.******.***.******",
  "domain_path": "",
  "domain_set": true,
  "duo_host": null,
  "duo_ikey": null,
  "duo_skey": null,
  "email_attempts_limit": 3,
  "email_expiration_time": 600,
  "email_token_size": 6,
  "emergency_access_allowed": true,
  "emergency_notification_reminder_schedule": "0 5 * * * *",
  "emergency_request_timeout_schedule": "0 5 * * * *",
  "enable_db_wal": true,
  "extended_logging": true,
  "helo_name": "****.***.******",
  "hibp_api_key": null,
  "icon_blacklist_non_global_ips": true,
  "icon_blacklist_regex": null,
  "icon_cache_folder": "data/icon_cache",
  "icon_cache_negttl": 259200,
  "icon_cache_ttl": 2592000,
  "icon_download_timeout": 10,
  "icon_redirect_code": 302,
  "icon_service": "internal",
  "incomplete_2fa_schedule": "30 * * * * *",
  "incomplete_2fa_time_limit": 3,
  "invitation_org_name": "Vaultwarden",
  "invitations_allowed": true,
  "ip_header": "X-Real-IP",
  "job_poll_interval_ms": 30000,
  "log_file": null,
  "log_level": "Info",
  "log_timestamp_format": "%Y-%m-%d %H:%M:%S.%3f",
  "login_ratelimit_max_burst": 10,
  "login_ratelimit_seconds": 60,
  "org_attachment_limit": null,
  "org_creation_users": "",
  "password_iterations": 100000,
  "reload_templates": false,
  "require_device_email": true,
  "rsa_key_filename": "data/rsa_key",
  "send_purge_schedule": "0 5 * * * *",
  "sends_allowed": true,
  "sends_folder": "data/sends",
  "show_password_hint": true,
  "signups_allowed": false,
  "signups_domains_whitelist": "",
  "signups_verify": false,
  "signups_verify_resend_limit": 6,
  "signups_verify_resend_time": 3600,
  "smtp_accept_invalid_certs": false,
  "smtp_accept_invalid_hostnames": false,
  "smtp_auth_mechanism": null,
  "smtp_debug": false,
  "smtp_explicit_tls": false,
  "smtp_from": "******@***.******",
  "smtp_from_name": "Vaultwarden",
  "smtp_host": "****.***.******",
  "smtp_password": "***",
  "smtp_port": 587,
  "smtp_ssl": true,
  "smtp_timeout": 15,
  "smtp_username": "******@***.******",
  "templates_folder": "data/templates",
  "trash_auto_delete_days": null,
  "trash_purge_schedule": "0 5 0 * * *",
  "use_syslog": false,
  "user_attachment_limit": null,
  "web_vault_enabled": true,
  "web_vault_folder": "web-vault/",
  "websocket_address": "",
  "websocket_enabled": true,
  "websocket_port": 3012,
  "yubico_client_id": null,
  "yubico_secret_key": null,
  "yubico_server": null

Again, I don’t think the Bitwarden community forums are appropriate if you are having issues with software from another provider, particularly software that seems to brand itself as being associated with Bitwarden whenthat is not true at all.

1 Like

I have the same problem: “An unexpected error has occurred” when logging in from the chromium browser extension in Linux.

I can access my web vault from that same browser, but not login with the extension.
And yes, I triple checked my email address and password when I entered them in the login fields in both the browser extension and the web vault.

As a side (unrelated?) note, this is the first time in a long time that I tried to login to bitwarden with that computer.

Hi @OroshiX - can you confirm that you are accessing your web vault at https://vault.bitwarden.com?

Hi @dh024, Yes I confirm

OK, it sounds like credentials issues or that something may have been corrupted in your browser profile then. Here are a couple of things you can try:

  • triple-check that you are using the correct login name (email address) when you login
  • Uninstall the BW extension, restart the browser, and reinstall (that often fixes these issues)

Let us know how you make out!

The second solution is what worked for me (uninstall extension => restart => reinstall)
Thanks for your help @dh024

1 Like