YubiKey with USB-C on Android

I’m trying to use my Yubikey 4C on Android with the Bitwarden app, but for some reason it doesn’t work at all. When I press the button on the YubiKey it doesn’t seem to be detected by the app at all. The only YubiKey<->app interaction I can see is that when I plug in/out the YubiKey the app jumps back from the 2FA page to the login page.

Anyone else getting the USB-C key to work? I’ve tried to fiddle around with the permissions (the app has usb permissions) but can’t find anything solving the problem.

When I’m using my YubiKey 4 NEO with NFC it works like a charm…

I’ve just run into the same behavior using a Yubikey 5 NFC (via USB) on both a Moto G6 and Nexus 5X. Did you ever find a solution?

Same here with Yubikey 5C NFC using USB on Samsung Galaxy S9

Funny side note I can’t use NFC because of issue with my phone when battery is below 70% NFC is not working :confused:

Interesting, does it matter if it’s OTP or U2f?


When removed all OTP keys, and register FIDO U2F only app says there is no possible way to authorize.

Based on online doc it does not appear to support u2f on android

I’ve just solved the issue. In order to use Yubikey 5c I need it to be inserted into usb at the beginning of the process (i.e. on the view where user chooses login button), then on 2nd factor view, focus on key input field and touch yubi icon on the yubikey.
I tried that earlier without a success. It was because on dark mode input field on 2nd factor view is not visible (at least to me) and I didn’t know I need to focus inside it.
Anyway, glad that it’s working because I started looking for alternatives (Keeper, 1Password) but I’m still thinking BitWarder is the best.