YubiKey OTP registration error

today I bought premium and tryed to register my YubiKey.
I followed the help page, but noticed I didnt had the YubiKey OTP enabled / created. So I used the YubiKey Manager and setup an new OTP . I selected to use the serial ID for the Public ID and randomly generated the Private ID and the Secret Key.
After that I headed back to the bitwarden page and tryed to register my yubikey again.
But I then throw an error which said “Key1 is invalid.”
Have I done something wrong?
Thanks for any help :slight_smile:

Try your key here:

Does it work with OTP? If not, you should contact yubico support to figure out why.

Ah okay, I found my mistake. I fogot to also upload the generated data.

I just tried my key, the YubiKey 5 NFC which is brand-new and it works and is registered on the demo.yubico.com site. Still get the unhandled server exception when trying to register the key…

I had the same issue. (“Key1 is invalid.”)
Had to reconfigure my key’s public identity to start with “vv” to be able to upload the config to https://upload.yubico.com/ After that it was accepted in the registration page.