Web vault should open records in View mode before Edit mode

In the web vault there is no option to open a record in View mode before Edit mode. I suggest it be changed to align with the browser extension behavior, where records open first in View mode with an option to Edit. I frequently open records to copy text from their notes, and currently in the web vault it is too easy to accidentally edit the note text while copying and then accidentally click Save instead of Cancel.

You’re absolutely right. I came to the forum to ask this exact question. I am surprised this doesn’t bother more people. I have lost a few passwords when I open a record, in Edit mode because that is what it goes to automatically, because mysteriously the entry in the password field gets replaced by my master password … and I didn’t even want to edit the record in the first place.

@JVD Welcome to the forum!

Most people use the Web Vault only for account management (changing security settings, renewing subscriptions, managing organizations, creating exports, etc.), not for viewing vault records.

This is not mysterious at all. It occurs because you have instructed your Bitwarden browser extension to auto-fill your master password any time that you open a web page in the bitwarden.com domain where a password field can be found.

To fix this, you need to take any one of the following four actions:*

  1. In the browser extension, edit your vault entry for bitwarden.com, and change the selection for “Auto-fill on page load (if set up in Options)” from “Use default setting” to “Do not auto-fill on page load”. Don’t forget to Save. This will prevent automatic auto-filling of passwords on all web pages in the bitwarden.com domain.

  2. In the browser extension, go to Settings > Auto-fill, and change the selection for “Default autofill setting for login items” from “Auto-fill on page load” to “Do not auto-fill on page load”. This will prevent automatic auto-filling of passwords on all web pages except for those that you explicitly authorize (by editing the auto-fill on page load setting in the corresponding vault record).

  3. In the browser extension, go to Settings > Auto-fill, and uncheck the check box for “Auto-fill on page load”. This will completely disable automatic auto-filling of passwords by the browser extension.

  4. In any Bitwarden app or browser extension, edit your vault entry for bitwarden.com, and change the value of the URI 1 field to exactly https://vault.bitwarden.com/#/login, and delete any other URI fields (URI 2, etc.) if they exist. Next, modify the “Match Detection” selection for URI 1 so that its setting is “Exact” instead of “Default match detection” (except for in the Web Vault, you will first need to toggle the visibility of the “Match Detection” dropdown selector, by clicking the :gear: gear icon next to the URI). Don’t forget to Save. This will restrict automatic auto-filling of your master password to occur only on the actual Web Vault login page, preventing the master password from auto-filling when you are viewing vault records.


* Edited to Add:

Since it appears that you discovered and installed the Bitwarden browser extension an hour after writing your comment above, it is possible/likely that it was a Password manager other than Bitwarden that was auto-filling your master password into the Web Vault records. If that is the case, then the fixes suggested above will not work.

Please make sure that you have uninstalled any other password managers, and fully disabled all password management/autofilling functionality in your browsers. One way to accomplish the latter is to go to Settings > Auto-fill in the Bitwarden browser extension, and check the checkbox for the option “Make Bitwarden your default password manager”.