Unlock with PIN setting cannot be set

I have set the PIN countless times on Linux and Windows machines over the years but today, whilst installing Bitwarden desktop for Linux I cannot set a pin. Once in settings I go straight to ‘Unlock with PIN’. Normally, when I check that box a popup appears for me to enter a PIN. Today in
Version 2024.3.0
Shell 28.2.4
Renderer 120.0.6099.291
Node 18.18.2
Architecture x64
in Linux Mint 21.3 there is no popup. I cannot go further because there is no box to enter the PIN. This was BW installed from Flatpak in the Software Manager. Thinking this might be a corruption in that installer I uninstalled it and downloaded the appimage from the BW website. That exhibited the same problem. Thinking further that it might be a Linux Mint problem I installed BW in KDE Neon on the same machine, that copy installed from Neon’s software manager. The same problem again.
As an aside the BW extension used in Vivaldi browser on all machines works as expected in this respect.
Have others found this problem on the latest version of BW? Can anyone offer any help to get it fixed?

I am using Kubuntu 22.04 and have the same problem that you have described. I used the snap version of bitwarden and could not setup a PIN. I have also tried to setup a PIN in the AppImage version but failed. The expected popup window does not appear.

Having the same issue with all current versions of Bitwarden for linux.
AppImage, FlatPak and Snap.
No popup asking for pin when PIN is enabled, just ticks the box. Go out and back in, box is unticked again and no change.

Had been working, but I don’t know which version was working and what version it stopped working on. Prior to me reinstalling, I had PIN ticked in settings as I had set it up that way when I first installed.

I noticed there was a problem when it started asking me for a password instead of a pin, and then when I tried to turn off pin and put it back on again, realised it was no longer working.

1 Like

The good thing, though, is that the browser extension works with PIN. I plan to send mail to Bitwarden Support about this problem.

@Teofil & @wheeljack Welcome to the forum! @rafikiphoto Welcome back!

What you are describing seems to be consistent with a bug that was recently reported on GitHub:


You can track the progress on any upcoming bug fix there.

1 Like