Unhandled server error after click on email verification

Hi,
so far my bitwarden installation on debian linux buster runs fine,
but when I click on the email verification an unhandled server error occurs.
I setup the smtp-variables in bwdata/env/global.overrirde.env like this:

[email protected]
globalSettings__mail__smtp__host=127.0.0.1
globalSettings__mail__smtp__port=25
globalSettings__mail__smtp__ssl=false
globalSettings__mail__smtp__username=klaus
globalSettings__mail__smtp__password=XXXXXXX

when I try to send mail from the console via “mail” (logged in user klaus) to the address setup in bitwarden it works fine

Hello @klausH,
try these settings: (fill the rest of course :slight_smile: )

globalSettings__mail__replyToEmail=
globalSettings__mail__smtp__host=
globalSettings__mail__smtp__port=587
globalSettings__mail__smtp__ssl=true
globalSettings__mail__smtp__username=
globalSettings__mail__smtp__password=
globalSettings__mail__smtp__trustServer=true

In my case it works without any problem. In my case I have encrypted connection (…ssl=true)

Many thanks for Your answer!
I tried it (the last line I had to add as it was not present in the conf).
After changing I did stop - rebuild - start.
But it’s still the same. Is there any log entry to see what’s really going on?

I found this in /var/log/messages at exactly that time:

Aug 20 09:41:39 miraculix dockerd[2706]: time=“2020-08-20T09:41:39.574660841+02:00” level=warning msg=“Health check for container b3f688e864474dc124256836a8a16135989371c15ff38963cfedabbdee25a490 error: context deadline exceeded”

Yes, go to docker-compose.yml directory and run docker-compsoe logs -f (cancel with crtl+c)

If you can not go further, check my example:

Run ./init.sh and change the email settings. If you have already vagrant and virtualbox it should take you no time. This will tell you if your email server is set up correctly but not if you have any other problem on your setup :wink: .

This should be the problem:
bitwarden-api | fail: Bit.Api.Utilities.ExceptionHandlerFilterAttribute[0]
bitwarden-api | Connection refused 127.0.0.1:587
Thanks, I’m working on it …