Unable to login on Android

Been a new user for a couple weeks with no issues. Two days ago I couldn’t login on my phone. This morning I couldn’t login on my tablet. Both return the message "An error occurred
exception message: The operation was cancelled. I can login on the web. Triple checked password, cleared cache and data. Reinstalled app. Tried earlier version. No luck. Any thoughts?

Hi Gary,

What is the internet connection used when this issue is reproduced?
Is it your mobile operator? Do you use some VPN, Firewall or similar network layer security or some app, blocking network connections for specific apps?

Try to use same Wi-Fi as your PC uses, when successfully connected to vault and make sure no security features are active at that time - just to exclude network related causes

Appreciate taking your time to try to assist. I have only logged in using my home wifi and I logged in no problem until as I said, a few days ago. I tried using data on my phone and connected okay. Went back to wifi and now it’s working with my phone. Blew the dust off I guess. Still can’t login on my tablet. No data with that.

1 Like

Solved. Tethered tablet to phone to use the phones data. Connected that way. Logged out and went back to wifi and now I can once again login using WiFi. Strange.


I have a similar issue. Bitwraden will not sync, save, etc when I am connected to my wifi(gives erros). However, if I turn off wifi, and use LTE data it works just fine.

Very strange.
Pls fix.

I’m not an expert in BW application, but to me it looks like there are some issues with your Wi-Fi configuration or with your ISP, as I assume that BW didn’t implement it’s own network communication library for Android, but instead, is using standard Android one, which should make it transparent for apps what network is used: mobile (LTE, GPRS, CDMA or whatever else) or Wi-Fi (a, b, g, n, ac, other). So, if my assumption is right, there is nothing to fix in app code and you need to find the difference on your network layer

Hello, same problem occurred to me today on a Fairphone 3+ with /e/ OS and I tried this solution. It works fine now, thank you.

Thanks @Fealthas. I had the same problem but I resolved it by switching off the WIFI and using the mobile network. Same issue when trying to add new login as well.

But once I get it working I can then go back to WIFI and everything works as expected.

Very strange.

For people with this issue, does other apps work on wifi. What happens if you turn off mobile data entirely and try apps other than Bitwarden?

I also am having trouble using the bitwarden app for android when connected over wifi. The app hangs every time it needs to communicate. Forcing my phone to cellular data solves the issue. Have not noticed the problem over other apps. Did not have this problem with oneplus 6T. Now experiencing it with samsung s21 ultra.

Hi everyone,

Can someone that is experiencing this issue please perform and answer the following:

  1. Please install Termux and ping (identity.bitwarden.com) through mobile and Wi-Fi, and share a screenshot of the result of each ping. This would check if the domain is being resolved correctly on both networks.
  2. Please connect to a different, safe, and trusted Wi-Fi network and check if that same Android client is working properly on the other Wi-Fi network.
  3. Please install the F-Droid client (Bitwarden on F-Droid) and let me know if it exhibits that behaviour or not.
  4. Please set your device inside your Router’s DMZ (DMZ (computing) - Wikipedia) and let me know if that changes anything.

Thank you in advance,

1 Like

This is exactly the same response that I received when I contacted you privately.
Not sure why the customers should do the diagnosis for you since… I am paying you…but…ok…

  1. Installed Termux and pinged “identity.bitwarden.com"
    Worked perfectly both, on WIFI and 4G with 0% packet loss and between 20-50ms
  2. Took the tablet, SAMSUNG TAB S4, to a shopping center, connected to their unsecured WIFI and yes, BW did log on and sync in less than 2 seconds.
  3. Uninstalled my version of BW and reinstalled the one from F-Droid. BW behaves the same, no log on or sync on WIFI and no issues whatsoever on 4G
  4. Did set the tablet through Router’s ( Tp-Link AX5400 Wi-Fi 6) DMZ, no improvement whatsoever.
  5. Did “forgot” and reinstate the WIFI network many times. Not good.
  6. As the ultimate try, I reset the tablet to factory settings and installed BW from Google Play, as the only, single, app on a clean-slate tablet. Still NOT GOOD!!!
    Also, a suggestion that MTU is the wrong size, I’m not buying it since once again, everything else, except BW, works just fine.
    No VPN either.

It is clearly a problem on my (and many others) WIFI network since, without any other tests, it worked in an instant on another network. But since I have more than a dozen gadgets connected to this router that connect to the Internet perfectly and some 30 apps on this particular tablet that, they in turn, connect to the internet perfectly, it is BW app that is just not smart enough to “talk” to the router properly and go through.

FIX IT, if you want to call yourself a LastPass replacement contender!!!

Hey @shrek - do you have access to a VPN? If so, can you connect over wifi through your VPN and try logging in/syncing?

If that worked, I would wonder if the Bitwarden servers are filtering your IP - I have seen this sort of thing happen with clients when they repeatedly entered the wrong password into their mail apps and the server blacklisted them automatically. Perhaps this is something the Bitwarden folks (e.g., @SergeantConfused or @tgreer) could comment on?

Oh well…it would never cross my mind!! Yes, I have NordVPN on my tablet but I hardly ever use it. I fired it up and guess what… BW logs on and synchronizes in under 2 secs. And yes, I have a dynamic IP address but my ISP changes address so very, very rarely that I may as well call it static.
I’ll be darned. I’m fitting with it for months and months, what an annoyance!
Thank you very much for, a great suggestion and for thinking outside the box!
But what about the people that are in the same boat complaining about the same exact issue, what now from here???

For who is interested and may help, turns out that the culprit is the IPV6 in the router. Turn that off, everything works just fine. Turned it back on…problem reappears!
On Android, BW is not negotiating IPV6 addresses properly (no such issues on iOS). Hopefully, a fix will come soon since there is no escape from the coming of IPV6.


This still appears to be an issue as of 12/13/21. Disabling IPv6 on my router worked for me. Were there any updates on fixing this issue? This seems like it would be a serious problem for users that can’t access the router

I was having this issue as well, and it turned out that the Android app was the culprit. I paused it for 15 minutes and was suddenly able to log in to Bitwarden without issue. Strange though that Bitwarden is the only app to have this issue, ideally this should be fixed so there’s no incompatibility.

I never had this issue before, but it seems to have appeared since the last update on February 14th. I tried reinstalling versions from google play and also fdroid, and none of them could connect. Checked private dns settings, it doesn’t work with or without it on. It doesn’t work with my wifi at all, only with mobile internet… And it’s the only app that’s not working.

The same issue( Galaxy Note 10+ Android 12

Same issue OnePlus 7T

Cannot connect on home WiFi - BT Fibre in UK via Linksys Velop, nor on holiday in France via Nova mesh.