Unable to log into self-hosed VaultWarden from extension

I’ve been using a self-hosted VaultWarden for about a year with no issues. Due to the recent news with LastPass I decided to update the KDF iterations. I went into my web vault and changed it to 1 million (simply added 0). After changing that it logged me off everywhere. OK fine. So I go to log in and it says my password is incorrect. Now I know I know my username/password for the BitWarden extension! I use the extension on Chrome/Brave and Firefox. None of them can log in. I can log in by going to my self-hosted VaultWarden web vault site. Using my normal email address and master password works fine, but the browser extensions don’t. My phone also still works but the fingerprint login failed. I put in my normal master password and got in. But again, I cannot get into BitWarden using the BitWarden extension in any of the browsers.

I tried reinstalling the extension on Firefox - same problem - password does not work.

Luckily I exported my vault to make sure I had a fresh copy. From the web vault all logins are still there.

Went over to my laptop (was on my desktop before - laptop is running Ubuntu 22.10 while desktop is running Ubuntu 22.04). Checked FireFox and Brave. BitWarden showed that it was unlocked but it had nothing in the vault (well it had 8 credit cards, all with no information at all and 0 logins). Also checked Brave, same. Logged out of BitWarden and tried to log back in. Failed on Brave, worked on Firefox! And FireFox’s had all of my logins and credit cards! Brought up Chrome, unable to log in. Logged out of Brave, unable to log in. Both Brave and Chrome reported username and/or password invalid. Can’t get in there! Went to FireFox and locked BitWarden. Tried my known master password to unlock BitWarden in FF, worked. Tried a log out and log back in… Worked.

OK so between the desktop and the laptop the only browser extension that is working is FF. Interesting but the BitWarden extension on the desktop FF is 2022.12.1 whereas the laptop FF is 2022.10.1. I’m afraid to try to update the extension on the laptop.

I also tried restarting the various browsers but that didn’t help either.

I thought of changing the iterations back down to 100001 but I worry that I’ll screw up things even more.

HELP! How do I fix this?

maybe check vaultwarden forums… this is bitwarden

Yes and it’s the bitwarden extension client that is failing here. Vaultwarden works!

More data, on the desktop I downgraded the extension for FF to 2022.10.1. Remember FF 2022.12.1 was failing on the desktop. Now it works!

Seems to be a bug between the BitWarden extension and a Vault that has 100000 KDF iterations.

Gotta look for downgrades for the Chrome/Brave browsers…

Vaultwarden typically packages a custom build of the web-vault with some minor tweaks to work with Vaultwarden, the web-vault version is pinned to your server version.
Updates to Bitwarden clients can, and have been shown to break things between an older Vaultwarden server and a newer Bitwarden client and so since the issue is with the unofficial 3rd party Vaultwarden server you will need to bring the issue to them and await a fix.

The Bitwarden forums are for official product use and issues related from the official project.
The devs at Vaultwarden will tell you to raise an issue here in the official forums if and when an issue in Vaultwarden is reproducible in the upstream Bitwarden and the issue stems from something unrelated to Vaultwarden.
It seems your issue is related to Vaultwarden, hence the suggestion to visit the Vaultwarden forums for further support.

More data…

Downgraded the BitWarden extension on all browsers, logged into VaultWarden without issue. Updated BitWarden extensions on all browsers and they work with my “old” VaultWarden server. Seems to me like BitWarden tripped over some such format of the vault and fixed itself.

I run VaultWarden on Synology in a Docker container.

Old version is 2.25.0
New version is 2022.12.0

Version obtained going into the Docker container and looking at web-vault/version.json

Posting this breadcrumb in case anybody else experiences a similar problem.

I am not sure specifically what you mean by

going into the Docker container and looking at web-vault/version.json

But you may have a separate web-build, unless you are saying you actually checked into the pre-packed Vaultwarden container to check the web build version.

Regardless, this is again just the web-vault, and for your Vaultwarden server you should check the version of Vaultwarden itself by going to the /admin panel and checking under Diagnostics, the current release should be server version 1.27.0

As mentioned this is a known issue with an older server build, though again I encourage you to visit the 3rd party community forums for your appropriate Vaultwarden issue.

Not sure where this /admin panel is supposed to be. I saw no button for it and if I changed it to say /admin I got

The admin panel is disabled, please configure the 'ADMIN_TOKEN' variable to enable it

As Winnie the Poo used to say “bother”. I don’t know what an ADMIN_TOKEN is supposed to be nor how exactly to set it. Seems like more trouble than it’s worth.

With docker containers often there is a “version” file of some sort often in /. I go into the Docker container (docker exec -it <container> bash) and look around for a version file. Here is was under web-vault. I checked it before and after and those were the numbers. YMMV.

Glad to hear you got it resolved.

For future Vaultwarden related issues, I urge you (or anyone else) to check into their appropriate community forums as mentioned, of course if you have Bitwarden related concerns then the community here will be happy to assist :slightly_smiling_face:

I will go ahead and close this for now as it is unrelated and resolved.