Timeout not working?

Hi, new user here. Using the Firefox browser extension, Bitwarden doesn’t seem to ever timeout, regardless of what timeout value I set for it. It just never times out and locks.

In Chrome it works fine.

Now I’m speculating here but: FF is my main browser and I’m in the habit of leaving several browser windows open, and often with many tabs open, including things like news aggregators etc. Could it be that auto-refesh/push notifications on these tabs is causing BW to see constant activity?

By contrast I rarely use Chrome and don’t leave tabs open in it.

I did check for other topics on this but the ones I found seemed rather different hence starting a new one.

TIA

I have the opposite problem with Firefox. No matter how long I set the timer (other than ‘never’) it forces me to re-enter my master-password whenever I restart the browser. Occasionally it works correctly, but mostly not. I’ve begun setting the timer to ‘never’ but that not secure.

https://bitwarden.com/help/article/vault-timeout/

!Regardless of Vault Timeout settings, closing the Browser or Browser Tab will end your Web Vault or Browser Extension session , meaning you’ll be required to log in to access your Vault.!

One of the security settings is ‘On Browser Restart.’ How does that differ from the ‘4 hours’ setting if both require you to enter the master-password every time the browser is restarted? I’m new to Bitwarden, so still working through the details.

OP here - my topic was that my BW browser extension never times out and locks. Any solution to this please?

Yes, same issue here with Chrome - BW never times out regardless of the timeout setting. I’m migrating from LP and looking for an alternative, but having BW remain logged in as long as the browser is open is a security issue.

Currently "X hours" is an additional condition on top of "On Browser Restart". It is best for someone who doesn’t restart their browser that often and wants security of an extra lock scenario.


In theory, background activity shouldn’t matter.
Hard to say what is exact issue.

One possible situation is Firefox’s Bitwarden sidebar is open on one of your windows (lock timer doesn’t start until all sidebars and extension popups are closed).

Maybe also try reinstalling extension (or toggling manual lock) and experiment with short timeouts to see if they work.

There are various people who reporting seeing something similar, but there is nothing consistent enough to determine exact reason:


Hard to say what is reason with current information.
If you consistently have issues, you may want to open a bug at Issues · bitwarden/browser · GitHub with more details on your system so that a developer can comment.

I have only seen Vivaldi (a Chromium browser) never timeout, which is due to Vivaldi bug (Vivalidi, Linux Mint - Automatic Lock doesn't appear to work · Issue #1037 · bitwarden/browser · GitHub).

It generally worked for me on fresh install of a Chromium-based browser (Google Chrome, Brave, etc) and Bitwarden extension.

Maybe try doing a new install of another browser (Google Chrome Beta/Canary) and only install the Bitwarden extension and see if it works.

There may be something about your particular setup (OS, other extensions, versions, etc.) that is causing issue.

Vault Timeout Never hasn’t been working on the android app for me for months. With the new update it’s just started a few days ago with the desktop chrome plugin. Since Bitwarden is open source I try to be forgiving about issues but this is ridiculous.

I wonder if this was miraculously fixed in the latest browser plugin update (1.56.4) ? I’ve been using Chrome on OSX (10.14) and the timeout feature finally started working!! :tada:
It’s a GREAT feature and one that I think is underrated in terms of security. I often don’t quit my browser after every use. If I happen to have my laptop lifted, there’s a good chance my vault will be locked before someone can get in there and start exporting passwords.