Taskbar icon and pw login

Hello: BW premium, new user. I saw a post (cannot find again, right now) from last yr. that the BW extension needed to be pinned to the browser menu bar.

This is Moz Firefox dev build w11p. Extensions in settings shows BW but I do not see a command to pin the extension (r mouse or otherwise). This is also true for chrome stable - BW prem ext is there, but no icon on address bar. As w/FF, no “pin to menu bar” r mouse or otherwise cmd seen.I also have BW “app” program active, but again no “pin to menu bar” . How can I pin something I cannot find?

Ques. 2: Every time I open BW, it starts by asking me to log in w/master password. I don’t want to log in every time, I’ve had to log in 3x (once here, 2x on FF), laptop was not turned off, BW should stay active.

Ques. 2+: autoruns is installed on this laptop. What if I stuck a link in w11 startup items for BW? Will it load, and also show in autoruns, & will I have to again, type in the master pw on initial boot of the day? Thank you.

@psl Welcome to the forum!

Instructions for pinning the Bitwarden extension in Chrome, FireFox, and Safari are available at this link:


In the browser extension, go to Settings and set the Vault Timeout Action to “Lock”. Then, enable Unlock with PIN or Unlock with Biometrics. For security reasons, it is recommended to not disable the option “Unlock with master password on browser restart”.


The master password is used to extract the symmetric encryption key that is required to decipher the vault contents; the encryption key is normally kept only in memory and not written to persistent storage on your device (e.g., saved to disk). Therefore, to prevent having to enter the master password on reboot, Bitwarden would need to store the account encryption key on the device harddrive, where it is vulnerable to theft. Bitwarden can be configured to do this (e.g., by selecting a Vault Timeout period of “Never”, or by disabling the option “Unlock with master password on browser restart”), but this is discouraged for reasons stated.

Tx GRB, but the “pin” icon you highlighted does NOT appear in my w11p, extensions/add-ons, neither for chrome stable nor FFdev build. (So) there are NO “unlock w/PIN” nor “biometrics” choices. No can do. It does provided a button to log out, which then requires complete re-auth to log in again. That’s it. Tx.

Seems like you have two problems:

1. Browser extension icon is not pinned to your browser

In Chrome, do you at least see see the “Extensions” icon ( shaped like a puzzle piece :jigsaw:) to the right of the browser’s address bar? If so, what do you see when you click on the puzzle piece? If not, what happens if you access the following URL (in Chrome)?


Make sure that the Bitwarden extension is active (“On”). Do you browse in Incognito mode? If so, make sure that you enable the option “Allow in Incognito”. After you have done this, if the Bitwarden shield icon has not appeared next to the puzzle piece icon, then check again what happens when you click the puzzle piece icon. You should see the Bitwarden extension listed, and you should be able to click on the pushpin icon (:pushpin:) to “pin” the icon to your browser address bar; if you are in Incognito mode, you will need to temporarily exit Incognito mode (i.e., open a regular browser window using Ctrl+n) to complete the pinning procedure.

2. Cannot find the browser extension settings

First, you need to open the browser extension. If you were able to pin the browser extension shield icon, click on the icon. Otherwise, if you can at least see the puzzle piece icon, click that icon and then click on Bitwarden in the list. If this doesn’t work, try using the keyboard shortcut Ctrl+Shift+Y (while in Chrome). In Chrome, as a last resort, try using your browser address bar to navigate to:


Second, unlock your vault if it is not already unlocked. If you don’t know how to do this, please ask.

Third, look in the lower right corner of the Bitwarden browser extension window, where you should find a gear icon (:gear:) labeled “Settings”. Click the gear icon. This should take you to the Settings page for the browser extension. Here, you will find the options I was describing in my previous post.

Thanks GRB. I had not noticed the puzzle icons. Once found, I followed your instructions & will see next time how it goes on the having to input the master pw.