Suddenly can't login to my self hosted Bitwarden. App transport security policy requires the use of a secure connection?

I have been using bitwarden hosted on a raspberry pi for a year now. however today i was unable to add an item to my bitwarden, through the google chrome extension. So i logged out, and when i tried to login again i get an error failed to fetch. On my iphone i encountered the error has occurred and it says i need a secure connection?

Any help would be appreciated

turns out i can login to my bitwarden using a VPN.? why would that be?

Bitwarden server does not run on Raspberry pi. I suspect you are using an imposter - do you know where you were downloaded the software from? Itโ€™s not Bitwarden, but something impersonating BItwarden, which sounds like a terrible place to store all your secret credentials to me!

its a docker bitwarden install. is that not a proper install?

How did you install it? Bitwarden has no installer for Rpi.

Using the official install guide linked below.

What version of Linux are you running on your Rpi. I have never heard of Bitwarden installing directly to that platform.

it is installed via a docker container. the rpi is running the normal OS. This is an official install. and had been working for a year prior to this.

I am currently trying to figure this out. But it appears i cannot access my bitwarden, on my own network. when i am off it i can access it. Why would that be?

Honestly, I donโ€™t know. I have never heard of this being done with an official Bitwarden server.

There are imposters out there - software that claims to be Bitwarden but is not. I would urge you to triple-check that you are, in fact, running a legit copy of BW, and not something impersonating as Bitwarden. Assuming it is the latter, people here on the Bitwarden forums canโ€™t help you with someone elseโ€™s software, and you might carefully consider whether it is safe to be storing all your secrets on software that is actually an impersonator.

how would you like me to confirm for you that i am running an official bitwarden server.

I am not asking you to confirm anything. Just offering advice.

If you are running a legit BW server, I suggest you contact Bitwarden support - make sure to mention your Bitwarden installation ID and locate your key for verification. Let us know how you make out!

Following this thread.
As I understand Bitwarden only provides docker images compatible with amd64 from their official Docker Hub as all images are tagged as such, and do not support ARM, as is apparent in the Bitwarden System Requirements.

I believe with some workarounds there have been reports of users successfully installing the Official Bitwarden stack on a Synology NAS (as some of these devices do have an x86 processor, albeit most are ARM as well). But I have not heard of any way to install the full official Bitwarden stack on a raspberry Pi.

One method you may check to see if you are running the Bitwarden stack would be to view the docker services running on your rPi, typically with the command $ docker ps or some type of GUI such as Portainer.

Regarding access internally VS externally it sounds most likely as some type of network issue as one network functions and the other does not. This could be something like a DNS issue or possibly a proxy in the mix, but hard to say without further info on the setup. I would look to your internal network and try to see the cause, though it may also be due to an installation issue if it is a non-standard install.

1 Like

Since he never came back, I guess Ryan finally realized he wasnโ€™t running Bitwarden Server after all. Iโ€™ll mark this one as SOLVED and close the thread.