[Solved] Safari extension lost after upgrade to 1.25

I’ve got a reply from the team, basically the Safari extension for Bitwarden 2.50 won’t work with Safari 13 (it’s only compatible with Safari 14+). I copy and paste their workaround which implies downloading a previous version of Bitwarden, and disabling auto-updates

​As for the Safari 13 issue: our newest release of Safari Extension can only be used on Safari 14+: Release Notes | Bitwarden Help & Support

If you are still using an older version of Safari you shouldn’t upgrade to our latest version. But, if you have upgraded already, in order to install an older version, you can download the file from here: https://github.com/bitwarden/desktop/releases/download/v1.24.6/Bitwarden-1.24.6.dmg

Then, in order to prevent for the app to auto-update, you need to open a Terminal in your Mac (Applications > Utilities > Terminal) and set your environment variables with this step: echo “export ELECTRON_NO_UPDATER=1” >> ~/.bash_profile

2 Likes

Safari 14 is available for Catalina based on the info I’ve found googling.

Thanks very much. This solved the problem for me. I’m using Safari 13.1.2

I’m having the same issue. Just opened another support ticket. I’m on Big Sur 11.2.3.

Having the same issue since going to 1.25.

Reading the article about 1.25 needed to be added from the Mac App Store instead of via .dmg, I removed the app, re-installed it, and the Safari extension is still not showing up.

BW:Version 1.25.0 (516)
Safari: Version 14.0.3 (16610.4.3.1.7)
macOS Version 11.2.3 (20D91)

I’m having the same issue with the extension not showing. However, I’m on Big Sur 11.2.3 and Safari 14.0.3. Bitwarden is installed via AppStore.

I just submitted ticket to their GitHub if you wanna piggy back on that also: Bitwarden 1.25.0 Extension not showing in Safari 14.0.3 on macOS 11.2.3 · Issue #1718 · bitwarden/browser · GitHub

Ooops. Spoke too soon. The extension has disappeared again and this time I can’t get it back! This is a real pain as up until now Bitwarden has been brilliant and I’ve used it all the time. Without the extension button it’s not very user friendly any more so I’ll be using it a lot less. As a paying member, I hope it can get sorted again soon.

Can someone properly explain to me how this works? This doesn’t seem to do anything.

I wonder if part of the reason Safari 13 reverts and I lose the Bitwarden extension (like everyone else) is because the program is actually still updating itself. I have tried below, but it definitely doesn’t stop Bitwarden from immediately updating as soon as I attempt to open 1.24. Where do I have to paste this in Terminal? (In which folder?) and do I have to substitute something for “bash_profile” or something? Basically, what am I missing?

Thank you!

Then, in order to prevent for the app to auto-update, you need to open a Terminal in your Mac (Applications > Utilities > Terminal) and set your environment variables with this step: echo “export ELECTRON_NO_UPDATER=1” >> ~/.bash_profile

For those with Safari 13 and lower, please try this release:

Yessss, that got my extension back! Thanks, I’ll stick with this version for now…

I’ve been having the same problem with the Bitwarden extension disappearing in Safari 14 (14.03) - and yes I’d been around the loop of removing Bitwarden, making sure it was downloaded from the App Store, rebooting, etc etc - Safari wasn’t showing the extension as even being installed or available no matter what I did.
So I downloaded the Safari Technology Preview (which is basically a fresh install of Safari Safari Technology Preview - Safari - Apple Developer) - and it immediately spots the Bitwarden extension and allows you to add it. If you then open up ‘normal’ Safari it has then been triggered into spotting the Bitwarden extension again and works fine. You can then just remove the Safari Technology Preview.

I would guess (but haven’t tried) that just uninstalling and re-installing Safari would do the trick - but to be honest that felt a bit drastic.

2 Likes

Thank you @Culfri works for me, too!

1 Like

@Culfri, same here. Your solution fixed this for me. Thanks so much!

I am on Catalina 10.15.7 and Safari 14.0.3. I quite likely was using the older version of Bitwarden. Safari then needed to be updated or upgraded. Bitwarden Safari extension stopped working. I deleted all Bitwarden files, reboot and reinstalled using AppStore version. Went to Safari-Preferences-Extensions. No Bitwarden Extension!!!

I guess I am stuck with it by manually copy and paste the needful which is a pity until Bitwarden resolves this issue.

Thank you @Culfri works for me. I guess you might be right that the same results might work by uninstalling and reinstalling Safari. I am happy it is working now. So let it lay to rest for a bit till Bitwarden permanently address this problem.

thanks!! works fine now

hello i seem to have lost my Safari extension. Im still on BW 1.24.7 (frozen) and Safari 13.1.3. but my extension is gone this morning?? Any ideas what i can do to get it back. It was working flawlessly for a couple of months.

Thanks!

Why don’t you read first? The solution to your problem is mentioned and confirmed several times within this topic.

Seems i was able to restore the Safari extension by reinstalling the BW frozen version mentioned above.

1 Like