[SOLVED] Browser extension requiring Master password every time

I’ve been using the browser extension in chrome for a few months without any issues until today.

I hadn’t changed anything but starting this morning the bitwarden browser extension is requiring entry of Master password on every single login. The autofill shortcut ctrl + shift + l doesn’t auto paste and if I click the appropriate password in the vault, I get a prompt requiring Master password confirmation:

Master password confirmation
This action is protected. To continue, please re-enter your master password to verify your identity.

If I enter my master password then it fills in the login, but why is it requiring this on every login?
Anyone run into this / have any ideas?


Strangely, my vault has just locked itself and required my master password to get back in. It’s set to lock on browser restart, but my browser has been open for some time.

Yeah I have it set the same. But to be completely clear it’s not just occassionally without a browser restart - it’s every time I have to put a password in =\

If I had to guess, I would bet that your BW browser extension automatically updated this morning and it messed with some of your settings. You might have to go back in and change the vault timeout/lock settings.

It’s happening because ‘old’ vault data doesn’t have the reprompt flag in it at all, but a full sync will fix it. We’re also putting in a patch here:


Thanks @tgreer . Tried to do full sync. It didn’t go through. So, re-installed the extension to do full sync. It worked.

Thanks @tgreer ! It was a combination issue for me - I am using a letsencrypt wildcard cert and there was an issue with the renewal process which caused my certificate to be expired. This, in turn, interferred with a fresh sync operation. Once I fixed the certificate and gave it some time the issue seemed to be resolved (and I haven’t had any further issues).