[Solved] Android app no icons for logins

I don’t know about any of the others here but I suppose I should disclose that I’m running BitwardenRS server to host my own BitWarden, but I assume if that was the casue someone else here would have also mentioned it, but I guess I’ll chime in anyways :wink:

The issue is with the andoid app. It is not making icon calls. It’s been verified through network debugging. The question is what happened? The android app has worked fine for years. Why has it stopped making icon calls? There are no errors, it’s not making the calls. I surmise this is much more widespread, just that many are not reporting it. In the code is there a flag somewhere that was accidentally flipped to prevent icon calls? Please have your QA team check this out and work with the dev team on a fix. Thank you!

FWIW, I have three android devices and icons are working fine on all of the, and I have never noticed this problem before.

@dh024 I’m pleased it’s working for you. However, many of us are not having an equally satisfying experience on our android phones. Clearly, there is an issue on android phones for many customers. You’re one of the lucky ones who is not impacted by this issue, but for those of us who are, we would appreciate attention to this matter.

1 Like

Yes, I understand and I am very sorry this is happening to you. I just wanted to chime in with my experience so that people can get a sense of how widespread this is. No offense or insensitivity intended!

1 Like

Latest android update today I tested again, still no luck.

If I turn off the icons in the settings I get the generic “globe” icon for all entries, but if I turn it back on there’s just a blank space, no icons at all still.

Same exact behavior after update. Something is going on with android apps which is breaking the icons. It’s not affecting everyone, but is affecting some users. I’ve checked network traffic and no icon calls are being made. My android apps worked perfect for many years. One day it just broke not to long ago. Strange.

Thanks all! We’re continuing to look at this issue!

@tgreer - is there anything we can do to assist in any way for those of us having the issue? A log/debug process that we can share to you if needed?

I also see no web icons in the Bitwarden Android app and am running a self-hosted, LAN-only instance of Vaultwarden set up per the Wiki with Caddy reverse proxy and Duck DNS. In my case, the missing icons seem to be due to SSL CERTIFICATE_VERIFY_FAILED errors that occur when loading web icons, as reported at https://vaultwarden.discourse.group/t/web-icons-on-bitwarden-android/1239.

@tgreer I can verify that as suggested by @NotLikely38:
Setting Icons Server URL = https://icons.bitwarden.net under Custom Environment in the Android app displays the web icons correctly.

I tested it and instantly my icons are back. I’m not a dev, but it appears he was able to fix the app per #4 in his post:

…“I have no experience in C# programming but followed the suggestion in FFImageLoading Not Show Android 4.2 · Issue #1448 · luberda-molinet/FFImageLoading · GitHub and created an instance of HttpClient with SSL bypass in its handler for the FFImageLoading ImageService in MainApplication.cs. Rebuilt the app in Release mode and installed on my phone. The web icons now display correctly.”…

This is beyond my pay grade. Can your dev team have a look at this and create a fix in a future android app release?

I also ran into another issue, which seems like a bug. The android app does not persist the Icon Server URL. If I close and reopen the app, icons are gone. I logout and check custom settings and Icon Server URL is empty. So this is not a working workaround.

Thanks, @Collence! Great information re: URL persistence.

I’ll check in with the team and see what the latest is.

Thanks @tgreer, any update of this? Also, I’m thinking that maybe, and I stress the word maybe, the android app is somehow using a cached cert. How does one determine if an android app is using a cached cert?

Could the android app be caching the old cert? If so, how do I know? And then how do I wipe that cached cert?

Someone in the other thread on the VaultWarden site mentioned it could possibly be using the old LetsEncrypt cert that expired? I haven’t had any time to investigate this idea on my own time tho, super busy with other items but though I’d mention it here too.

Is anyone experiencing this issue doing so with the Bitwarden cloud services?

Yes, I have 2 bitwarden accounts, one self hosted and another on bitwarden servers. Both do not show icons

@Collence, have you tried the suggestion by @jjlin at https://vaultwarden.discourse.group/t/web-icons-on-bitwarden-android/1239/11?

I disabled the expired DST Root CA X3 certificate on my phone and the web icons immediately appeared again in the official Bitwarden Android app.

In settings, search for View security certificates and then disable Digital Signature Trust Co. DST Root CA X3.

1 Like

Yes :wave: but mine started working… not sure why. Just wiped cache again, after one of the beta updates.