SelfHosted BW: Cannot run bitwarden.sh / Missing file or directory


#1

Hi there,

I don’t know what happened, but I’m not able any longer to execute bitwarden.sh.

The error message is:

IOError: [Errno 2] No such file or directory: u’/var/services/homes//bwdata/docker/docker-compose.yml’

I never had any config files unter homes (they are located directly in several docker/bwdata directories.

Any idea, where this changes behaviour is coming from and how to fix?

Thanks,
Kingshill

PS: If I create all requested entries under /homes on my synology manually, I the the error

“couldn’t connect to Docker deamon at http+docker://localunixsocket - is it running? If it’s a non-standard location, specify the URL with the Docker_HOST env variable”


#2

I see nothing strange in that path, very similar to my Synology.
/var/services/homes on my box is a symlink to the homes folder on volume1:

[email protected]:~$ ls -ld /var/services/homes
lrwxrwxrwx 1 root root 14 Apr 23 17:15 /var/services/homes -> /volume1/homes
[email protected]:~$

If you open the Control Panel in the Synology webgui, do you have a shared folder called “homes”? Does the volume listed match the target on the /var/services/homes symlink?

I don’t have BW on my NAS (it’s too old) so I can’t help you with that bit.


#3

Thanks for your answer. I have updated my question already, to be more precise:

Yes, I have the home directories activated on Synology. However, they BW installation has never created any of those env files (e.g. mssql, global and the related override files) within the homes, but in the bw installation directory (which is /docker/bwdata/…).

So I’m confused, why the bitwarden.sh is now pointing to the homes directory.


#4

The error message suggests that docker isn’t running, what does docker ps say?

Did you recently update the docker app or the installed BW?

I would definitely get the mssql data and backups folders copied to a safe location…


#5

Docker is up and running. BW installation works - I can access it without an issue.


#6

Ah! I thought your BW had stopped working as well :slight_smile:
So only the bitwarden.sh script. Maybe it’s not the right one?
On my machine, bwdata folder was created in the same folder where I ran ./bitwarden.sh install When reading the script it looks like they try quite hard to ensure that.
Is there a /docker/bitwarden.sh maybe?
Or maybe try and copy it there?


#7

the script is located in /docker

From there I have installed BW in /docker/bwdata.

I could not find duplicated bitwarden.sh

–> As mentioned: It worked before so maybe any other setting (DOCKER_HOST?) has been changed. But I have no idea, where this setting can be adjusted.


#8

Looking at my /root/bitwarden.sh, how it calls /root/bwdata/scripts/run.sh and how run.sh exports COMPOSE_FILE="$DOCKER_DIR/docker-compose.yml", I simply cannot understand how this is possible.

What does your /docker look like? Is it a folder or symlink? (ls -ld /docker)

@Kingshill I’m all out of ideas, sorry.


#9

@BentTerp Thanks for that hint. I think she issue was, that I had two Bitwarden.sh files on my Synology:

/volume1/docker
and
/home/bwdata/

if I call the one in the installation director (docker), I don’t get the mentioned errors
anymore.

I think I need to cleanup / reinstall.

I just do a rebuild as root and it looks like it worked!

Thanks a lot for your support.

Best regards,
Kingshill


#10

Glad to be of help :sunglasses: