[Self-Hosted] Version of docker-compose not supported while installing


#1

Hi.

I’ve been trying to self-host bitwarden, but I’m runing into an issue when I’m trying to ./bitwarden.sh update (or start). It doesn’t work as intended and its output is :

Version in “/home/me/bitwarden/bwdata/docker/docker-compose.yml” is unsupported. You might be seeing this error because you’re using the wrong Compose file version. Either specify a version of “2” (or “2.0”) and place your service definitions under the services key, or omit the version key and place your service definitions at the root of the file to use version 1.

After quite a bit of looking around, it seems that this issue is related to some specific versions of docker and docker-compose not working together.
However, this seems to be fixed.


I’ve tried the following :

  • Deleting & re-running the install script several times
  • Running the install script with “beta” versions
  • Either generating a SSL certificate or not during the install
  • Keeping the default bwdata.config.yml or changing the HTTPS port
  • Creating the bitwarden directory in my home directory and at the root
  • Running either as root and as myself with and without sudo
  • Running the container with docker-config manually.
  • Tweaking bwdata/docker/docker-compose.yml to use version: 2.0, version: 2 or version: 3.1, either directly or by using bwdata/docker/docker-compose.override.yml

Config information

Linux Debian 9.8
Web server Nginx 1.10.3
Docker version 18.09.3 build 774a1f4
Docker-compose version is 1.8.0 build “unknown”
My user is in the docker group, and for each new installation I used a new key & ID from bitwarden.

I hope I provided enough information, and thanks in advance for your help.


#2

Same thing here. Had to change the version to ‘2’ before it would work.
Is this a bug? or are we installing the wrong version of something?


#3

I tried again and changed the version to ‘2’ in both /bwdata/docker/docker-compose.yml and /bwdata/docker/docker-compose.override.yml, and it seems to be working now.
Note that for me, changing it in only one of the two files didn’t work.
Thanks for the feedback !