Safari extension not working

Hey everyone,

Does anyone know why my Bitwarden extension has stopped working for Safari on my macOS? A few weeks ago I had it and it was working fine, but recently it disappeared from safari. I gave this a few weeks thinking it would come back, but still no luck. I checked my browser preferences and it’s gone from my extensions tab. Does anyone know what I can do to get it back and working? I also have Bitwarden downloaded from the App Store and using the latest version.

MacOS Version: Monterey version 12.6
Safari Version: Version 16.0

Thanks in advance for your help!

Hey there, this is an issue with MacOS LaunchServices, see Bitwarden 1.25.0 Extension not showing in Safari 14.0.3 on macOS 11.2.3 · Issue #1718 · bitwarden/clients · GitHub for more information:

  • OnyX and similar tools supports rebuilding the Launch Services database.
  • Install Safari Technical Preview, it seems to register itself as the new handler for Web Extensions. Which also makes the extensions available in the regular Safari application.
  • The following command re-registers Safari to the Launcher Service and worked on my machine /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -f -R /Applications/
  • If that doesn’t work try /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user which rebuilds the whole launcher service. Note the machine may slow down and finder can take a moment to become responsive while it rebuilds the database again.