Safari Extension not working on Catalina, Safari 15.4

After last actualization, Safari extension crashed. The extension is there, I log in, but my passwords are not shown. The app works correctly.

It sounds like something may have been corrupted in your previous session. Try logging out completely, restarting the browser and logging in again.

If that doesn’t work, try reinstalling Bitwarden. Let us know how you make out!

I did it all. Still doesn’t work.


This is how it looks.

What happens if you login to the web vault at Do you see all your passwords there?

Yes, the web vault is ok, the app works ok, it happens only on safari extension.

The extension stopped working for me as well. I’m on Monterey, Safari 15.4. I don’t even have the Bitwarden button anymore, it disappeared. The extension is not listed by Safari either.

The desktop app works just fine.

Hi @DarkStar, if you go into your Safari preferences, does it show under extensions? Does it show that it’s enabled for all websites?

No, it’s not on the list. That’s what I meant saying it’s not listed by Safari.

Have you tried resetting your launch service @DarkStar?

Just enter this line of code into the Terminal app:
/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user

1 Like

Thanks, that did the trick! :slight_smile:

1 Like

It’s still not 100% functional. The red badge with the number of recognized logins for the current website does not show and the keyboard shortcut (Cmd+Shift+l) stopped working. I have to click the Bitwarden extension icon with my mouse to make it work.