Safari extension badge with a lock?

Just getting started with BW. Spent few days getting BW installed, running and synched for two accounts and four devices. I have been able to get roughly 70 items entered. All was going well until the badge in my Safari extension started showing a little black padlock instead of the standard red number (showing items associates with that website.) Now I have to enter my master pswd for each and every little thing I do. Bad!

Seems to be for some “Private Mode”, according to the BW referenced help link (below). But that link only addresses Firefox, and is no help to me.

Does anyone know what this is and how I to get back to normal? I’ve been snooping around for a few hours, and can’t find a thing…

As they say, it was all going so well. Until it wasn’t…

Thanks! Bob

WARNING: Private mode support is experimental and some features are limited. Learn more

Hi Bob (@BobBl) - that icon with the padlock means that your vault has locked itself due to a period of inactivity. You can change your vault timeout options to set how much inactivity (if any) you would like to select before Bitwarden locks your vault automatically. You can also setup a PIN or biometrics (e.g., fingerprint) to unlock the vault so that you don’t have to enter your master password each time. More details can be found on the help pages here:

David - thanks for the quick reply! But that’s not what I’m observing. I can log back in, which should unlock the browser extension, but each time the browser extension is addressed (i.e., with every single website you look at, every single cut and paste you do, no matter how short the time interval…) I have to log in again. It’s like there is a zero second period of inactivity allowed! Even though it’s set for 4 hours.

I think something strange got reset in my browser extension, but I can’t figure out what it might be.

Hi Bob - I wonder if perhaps your browser profile became corrupted somehow. Often uninstalling the extension, restarting the browser, and reinstalling the extension will fix it. Let me know if that solves it for you. Cheers!

I think that worked. I trashed the OSX app + Safari extension and re-downloaded it. So far, so good!

Thanks for the help!
Bob

1 Like

Removed the extension, removed the app, deleted everything in Library with the name “bitwarden”, and still having the same issue. Any ideas?

Hey @Pepper, if none of the tips provided above helped, you can contact our support team here for assistance.

For me, the Bitwarden Safari extension had always been working well. But after recently updating from Safari 14 to Safari 15.5 on Big Sur, I am now running into the same problem described in this thread. I tried completely removing Bitwarden by using AppCleaner and reinstalling it, but so far no luck. When entering my master password I can use Bitwarden once, to choose the appropriate password, but it stays locked apart from that. The extension also shows me a warning about “Private mode support” being an experimental feature, even though Safari is not in private mode. Is this a known bug?

Here is a screenshot of the extension after having entered my master password:

Screenshot 2022-07-18 at 11.14.11

I’m in the same situation too.
Worked only once (and seems bit slow) after I enter the credential. After that boot, I can’t make the unlock status persist anymore.
Even disable extension & reinstall the Bitwarden App (from AppStore) doesn’t help.

For bug reporting purposes, is this the issue you are experiencing? Biometrics requires authorization on every page load. Mac, Chrome & Safari · Issue #3441 · bitwarden/clients · GitHub