Safari extension autofill breaks when vault is locked

I’ve been using (and loving) the Bitwarden browser extensions primarily with Cmd-Shift-L to autofill password fields, but recently I’ve switched to Safari (from Chrome/Edge) and it’s been very inconsistent. Sometimes the extension seems to lose the ability to background process, which means the passwords count badge doesn’t show on the icon and Cmd-Shift-L doesn’t do anything. Cmd-Shift-Y or clicking on the icon itself still works, however, and it will still recognize the website and fill passwords correctly when manually opened, it’s just annoying to do.

Fully quitting and restarting Safari has fixed it temporarily in the past, but as of right now the extension will not Cmd-Shift-L more than once in a session. I’ve tried disabling/re-enabling the extension via Safari Preferences > Extensions, killing the process in Activity Monitor, restarting desktop Bitwarden, restarting the computer, and even deleting and reinstalling the entire Bitwarden app. All of the above will let me Cmd-Shift-L once, and successfully fill the login, but reloading the page or opening a new one breaks the extension.

EDIT: Upon further testing, it’s only when I Cmd-Shift-L with a locked vault and it opens a new login page that this issue happens. If I manually unlock my vault from the extension, rather than just Cmd-Shift-L’ing, it works fine. This happens with Biometric Unlock or just the good old-fashioned master password.

Can anybody else replicate this issue, or point me towards resources for further debugging the problem?


Detailed system info:

  • MacBook Air (M1, 2020)
  • macOS 12.3 Beta
  • Bitwarden 1.31.3 (2320)
  • Bitwarden Safari Extension 1.56.5 (seems weird that this is a different number, but whatever)
1 Like

I’ve literally been able to reproduce this issue all day, and of course right after I post about it, it suddenly decides to keep working more than once. The only difference is that this time biometric sign-in wasn’t working, so I opened the extension and typed in my password rather than Cmd-Shift-L automatically opening a login page.

It seems that the autofill doesn’t work on the latest Firefox either. Can this be checked pls?

Does it make a difference whether you manually unlock the vault when you first open Firefox?

No, I didn’t. But even if I did, that’s not my use case. I don’t want to unlock my vault manually each time.

Sounds like we’re having different issues then. Mine is directly tied to whether I manually unlock the vault or not.