Problems with auto-filling of identities and cards

Same problem here. Firefox for Mac 124.0.2, Bitwarden 2024.3.1 extension. Since a few days auto-filling forms not working any more. I’ve just tried it in Safari (where I also have the Bitwarden plugin) and it’s working perfectly there. When I try to fill in a form automatically in Firefox, the Bitwarden plugin gives an error message ‘Automatic filling failed, fill in fields by hand’ (sorry have to translate this from my language I don’t have an English version).

Update: I’ve just discovered the auto-form-filing is not working when I choose my identity from the ‘Favorites’ (you see this when you click on the Bitwarden icon in Firefox). If I go to the identities menu and use the ‘fill form’ button on the bottom, then it does work! I have un-favorite this identity and added it again to no avail, it’s not working from the favorites section. Is this a bitwarden or a firefox issue?

2 Likes

@Remco1 Welcome to the forum!

I moved your comment into its own topic, because it was unrelated to the topic of the thread where you had originally posted.

I was not able to reproduce the issue that you are experiencing. However, I discovered a similar issue, which happens in a way that is slightly different from what you have described.

When you open the browser extension pop-up window, there is a navigation bar at the bottom, with 5 icons. In English, the first two icons are called “Tab” and “Vault”; the last one is “Settings”:

image

If you go to the “Settings” page and click “Options”, and then check (enable) the option called “Show identities on Tab page”, you will find that all of your identity items are listed on the “Tab” page (when you click on “Tab”). If you are on the “Tab” page and click any item shown there (including any of the displayed identity items), Bitwarden is supposed to auto-fill that information into the current webpage.

What I discovered is that this doesn’t work anymore — it always results in the following error message:

image

However, another way to auto-fill is to view the details of a vault item, and then click the “Auto-fill” button shown at the bottom of the displayed vault item details:

image

This method of auto-filling always works, whether I view the identity item information by clicking on the item in Favorites section of the “Vault” page, or after clicking “Identities” from the “Vault” page, or even by clicking the “View” icon for an identity item that is displayed on the “Tab” page:

image

 

Does the above correspond to your issue, as well, or are you describing something different? If your issue is different, then please try to provide additional detail about your situation (with screenshots, if possible).

Hi grb, thank you so much for this, this is EXACTLY the problem I was trying to report (sorry about putting it on a wrong page). I used to be able to click on the item on the tab page and it would auto-fill, and now that ressults in the red warning ’ Unable to auto-fill’ , etc. The auto-fill from the details does work for me too (though it’s a few clicks more).

Do you think this is a bug in Bitwarden or something do do with the (in my case) Firefox browser?

1 Like

In my case, it happens in a Chrome browser, so it is likely a bug in Bitwarden. Should be reported on GitHub. I may do so later, if no one else has done it.

Same problem here, Firefox on macOS (both latest)…autofill into forms on login widgets in web pages no longer works at all. All I can do that’s “auto” is use the method that slams the choices on the login widget in the web page (keyboard shortcuts?), and that often obscures stuff I need to read. So not helpful for me.

Thinking about going back to a version that could actually do autofill, but haven’t done that yet. I’m really tired of having to go to the Bit Warden Firefox extension drop-down and force it to “autofill”. Manual autofill, classic oxymoron.

This has been going on long enough that I’m currently shopping for another password manager. I like Bit Warden being open source and all, but this is something that I do 20 times a day, and it’s really wearing thin day after day.

I’ll try to report it on git, or at least “like” the report that’s there if already been reported.

Update: Have reverted to previous Bit Warden version (2024.2.0), and things are much easier for the time being. Probably missing a few bugfixes, but Bit Warden at least worked back in February :-).

1 Like

OP mentions only auto-filling of Identity items, and my own tests only found an issue with auto-filling of Identity items and Card items, but not with Login items.

Thus, your issue is probably different from the one discussed in this thread, and I would suggest that you start your own topic if you would like assistance from the user community.

Same issue here – Win11, Chrome and Firefox extension April update, autofill from main extension popup no longer works for identities and cards (“unable to auto-fill…” orange warning box), but does still work for logins. Autofill does, however, work for identities and cards if I click through to the specific identity/CC details and choose autofill from there.

2 Likes

Same issue with Win11, Brave is up to date Version 1.65.114 Chromium: 124.0.6367.60 (Official Build) (64-bit). No issues with login autofill, just the Identity.

2 Likes

Same issue here. Firefox 125.0.2 (64-Bit) on Windows 10.

1 Like

Thanks; it would help if you also provide the versions of your OS and browser.

done. edited the original post.

1 Like

Hello. I have same issue I am getting the warning of unable to autofill credit card information on websites but if I click on “view” icon then choose the “atuo fill” button from there it auto fills 100% correct. Whats the problem? How to fix?

Firefox: 124.0.2
Bitwarden: 2024.4.1
macos: 12.7.4

@Abandon1Password I moved your comment into a more relevant thread.

I’ve also edited the title of this topic to add “… and cards” (which are also affected by the same bug).

1 Like

+1 here… The issue is for me in both Ubuntu 20.04 and Windows 10 in Firefox. BW version was 2024.4.1, had to revert to 2024.2.1 as somebody here suggested and everything works like a charm now. BW devs should do something about it, it’s at least 3 weeks I was observing this issue and waiting for some hotfix, but nothing yet :frowning:

@Maros_Pekar Welcome to the forum!

Evidently, Bitwarden has created a fix for this issue, which should become available in an upcoming release:

2 Likes