Problem with device login / passwordless login starting today. Didn't have this problem before

I am having problem with device login that just started today. I have been using this for a while, and the last successful usage was probably 24 hours ago. I note there was a server software update (on github) about 5 hrs ago, but I am not sure if this is related.

  • I was trying to login the web vault (2023.2.0). I put in email, continue → login with device.
  • I got pop-up notification on Android (2023.2.0), tapped on that, got biometrics screen, got through, but didn’t see the approval page.
  • If I go the Android setting page, I see “Pending login requests”, tapping on that results in “We were unable to process your request. Please try again or contact us.”
  • Of course, try this too many times and the server refuses to let you log-in with a password altogether.
  • Android settings: Allow sync on refresh (on), Vault timeout (Lock, 1 minute), Unlock with Biometrics (on) , Approve login request (on)

Other things I tried:

  • Tried tapping the Android notification from the notification screen. Same result (BW opened, biometrics, no approval page)
  • Tried Android manual sync (wiping down, clicking sync on the sync setting page). Nothing.
  • Tried restarting Android app, i.e. wiping it away and then relaunching. Same result.
  • Tried rebooting Android. Same result.
  • Tried waiting for over half an hour. Closed Android BW, checked and still saw “Pending login requests”, tried logging in with device: same result. Also, logging in with the password (afterward) was refused. I suppose I should stop trying before I lose all access altogether now.

Is anyone else having problems?

Resolved? : well, I rebooted the carrier router (to change the external IP address), rebooted the PC (to recover leaked memory, in effect, also restarting the browser), tried again, and it worked. No idea what broke it. Temporary problem? My setup? My IP?

This is just one data point, but I just tried the above steps with the same versions and it is working as it should for me.