Pre-configure extension after the update that added the region setting

Hi there, we had a working configuration for deploying the chrome extension, but today I realized that new clients defaulted to the US region, the new settings under where you have to type your email address the first time you configure the extension.

I’ve also tried the desktop app, and even following the guide on the bitwarden website, the issue is the same. I’ve found in the data.json that there is a “region” settings and changing that value to “selfhosted” at least the app started working correctly. I’ve tried adding a new value in the registry similar to the one in the data.json in the same place we push the base url configuration, but it just doesn’t work.
As anyone found a solution?

Maybe with that setting we’ll finally be able to solve our only issue left (my issue is the last post): Pre-configure environment URLs for Windows / Firefox

Thanks, the team is working on this one!

Hi there, are there any news? Or maybe a page where I can check the status of the issue?
I’ve tried today with the 2023.7.0 version of the extension (that added the EU location), but I’m still not able to force a selfhosted setting

Hey all
We’re also looking for a solution with 2023.9.1. Is there a way to pre-populate the Self-hosted parameter?
BR Mamu

I’ve tried again with version 2023.9.1 of the extension but it still doesn’t work. I’ve added a region setting in the registry (both in the enviroment level and the one before it), but it has no effect.

Still that setting works in the desktop app. If anyone need it, you can pre-populate the desktop app creating a base data.json in %appdata%\Roaming\Bitwarden with this inside. Once the app is opened it will fill the json file with other fields.

{
	"global": {
		"theme": "system",
		"environmentUrls": {
			"base": "https://my.btw.server.com",
			"api": null,
			"identity": null,
			"icons": null,
			"notifications": null,
			"events": null,
			"webVault": null,
			"keyConnector": null
		},
		"region": "Self-hosted"
	}
}

Hello, we are facing the same problem regarding the browser extension. Is there anything new ?

I just tried again with version 2024.1.0 and nothing I tried worked.
They updated the documentation for the app with the region settings, but nothing new in the extention.

Hi, finally, by setting up a gpo creating only the “base=mybtw.server.com” entry it will work perfectly for the web extension. Great !

Hi, can you show your gpo settings since it’s not working for me?
Mine will create a base=my.btw.server.com registry settings in policies\google\chrome\3rdparty\extensions\myextensionid\policy\environment as shown in the image a few posts before this. It worked before they added the region setting.

I created the exact same thing (without the region attribute) but we are using the Edge browser, so the path is :
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Edge\3rdparty\extensions\myidextension\policy\environment

I configured the same policies for Edge, but I’ve the same problem as with chrome. I’ve to manually select self-hosted, because by default it still select “bitwarden.com”. And when I select self-hosted I’ve to push “click here” to reset to the default and then my server will finally show up. Same as chrome.
I’ve seen a german guy having my same issue, and I’m italian. What language is your windows if I may ask? Maybe it’s a localization problem…

It’s strange, this is the behavior I initially had on my computer but finally after doing a GPUPDATE and reboot it worked correctly. I am French.