Password generator option from the context menu is gone

I often use this convenient option to “silently” generate new passwords without showing them on the screen and now “Generate Password (copied)” option seems to be gone from the context menu entirely. Is this deliberate?
Extension version 1.44.2, Firefox (it seems the same with Chrome too), Windows 10.

Should be there - check to make sure you’re on version 1.44.2

bw
Ok, so that makes me a bit paranoid, because that’s what i see in the context menu now, only these three options and there definitely were five of them in the previous version.
My version is 1.44.2, i checked. I also tried installing bitwarden extension in another browser too (Chrome and chromium based Brave and Vivaldi, on both Windows and Linux). I also tried installing extension in another computer (Firefox) and that’s also what i see. Unless the behavior of the extension changed somehow in order to get that menu option.
The same result is when i right click extension icon in Firefox too:
bw2
And it doesn’t matter i am logged in or not.

And this is what i see in the menu when the previous version is installed in Firefox (version 1.43.4 from https://addons.mozilla.org/firefox/addon/bitwarden-password-manager/versions/) :
fgd
There are all five options with last two, that i don’t see now in 1.44.2.

Latest version of Firefox and BW ext. v. 1.44.2:
Screen Shot 2020-05-30 at 6.05.10 PM

Works for me. Wierd that it doesn’t for you.

Thank you. Really weird, i have no idea what is happening. I even reinstalled the extension to the same result. Granted, extension still works like it did before, but these two options are missing (and in the other fields it sometimes (varies by session) shows that my vault is logged out, but i can still see password options to choose for autofill or copy, so it works).
And i found that there is a keyboard shortcut that can be set in “manage extension shortcuts” in Firefox to basically do the same thing (default was ctrl+shift+9 which didn’t work and needed to be changed) - randomly generate a password and copy it to the clipboard, so that still works and thankfully i got around this issue by using it.

Maybe these two options can remain in existing installation when the extension is updated but will not appear in new installations and thus there is an issue that can affect some existing instances too?

Maybe you could try installing extension in another browser that doesn’t have it, just to check if the result is the same and all options are there (no need to log in)?

Hey Reny - so I tried installing the extension on Chrome, and I was able to replicate your problem. The context menu for the BW extension did not show the Copy Verification Code or Generate Password features. Strange!

But I was able to fix it in Chrome. I went into the extension settings and enabled “Allow access to file URLs”. As soon as I did this, the two additional menu items were visible again. I then disabled “Allow access to file URLs” and it continued to work. Strange indeed.

In case it is helpful, here are my extension permissions in Firefox - do they look the same as yours? Firefox has no option like Chrome for file URLs, but I do see BW has a permission in Firefox to “Store unlimited amount of client-side data” - I wonder if you have that permission, also, as the problem seems related to local files accessible by the extension.
Screen Shot 2020-05-31 at 8.00.07 AM

Thank you for your insights, it’s nice to know that the issue is somehow fixable in other browsers. And yes, i have the exact permissions that you have. So it’s really interesting, that our experience with Firefox BW extension differs. Other than that i don’t know what to try to get my extension back to normal.

Given that at least part of the problem is reproducible, you might consider submitting a bug report on the BW Github page.

Created an account just to follow this. I’m having exactly the same issue though it only started occuring 2 days ago.

It seems to tie in with my changing of various settings in about:config - privacy orientated ones.
I have the Firefox multi-account containers like yourself, so I thought it may be that and disabled it. I was wrong and the problem still persists.

Have you recently made changes to about:config? I’m thinking this could be the reason.

In the meantime, I’ll do some testing and report back with any results.

EDIT: I got nothing, perhaps the config’ settings being changed were just coincidence. Though my GF also uses BW along with FF, same versions and she doesn’t experience it. How very strange.

Strange indeed. Out of curiosity, have you tried creating a new profile on FF and seeing if the problem persists then? That would confirm whether it is related to your local settings.

No changes in about:config were done. I got the issue as soon as the extension got updated to 1.44.2. I would say, that, it’s a global issue, because if you would install the extension in another browser or firefox profile i am sure you would get context menu with two last options missing. dh024 here found that it can be fixed in Chrome, but unfortunately no such opportunity in Firefox. It just might not occur on existing installations due to some strange reason, that’s why not many are aware of this. Not much success on Github either, so i guess, we’ll have to wait until more cases arise.