Password always visible

I’ve been using Bitwarden for a month or two, and it seemed fine. Lately, my email and password have been visible for anyone to see (password only dots, but visible if the eye is clicked).

I’ve tried lots of ways to fix this but failed so far. I’ve managed to get the email to stay blank but the password is always visible. I’ve checked Chrome Settings and disabled Auto Sign-in (which will probably be a pain to use now), but it’s achieved nothing.

Does anyone have any idea what’s happening here? I usually manage fairly well with computer stuff but this has got me foxed.

Thank you in advance for any help you may offer.

Auto Sign-in may not be what you think it is for, apparently from my quick searches it is tied to auto sign in for Google related services in your Chrome browser.

You may instead need to disable the feature for your browser to save passwords, as well as possibly clear out any currently saved passwords the browser may have associated with any web URL (in this case Bitwarden) and delete the passwords so Chrome no longer offers them.

As mentioned in the article, I would highly recommend you have a backup of your data prior to deleting all your passwords.
These can be easily imported directly into Bitwarden via the web-vault if you haven’t already done so :slight_smile:

1 Like

Thanks for that clear information, Kent. I’m not very good with this kind of thing so that was really helpful. All the Google Chrome passwords are exported and saved now (to a protected folder on an external drive), and cleared, so they do not auto-fill. However, when I try to open Bitwarden, although the password section is not blank the email address still pops up. Surely this should be blank as well, no? I would have thought it was part of the security, as much as the password.

Another thing: when I’m logging into Bitwarden, it allows me straight in, even though I’ve got two-step login set up (by email). I should be getting a verification code sent to my email address. I’ve just checked and it is set up with my main email address, even though I use a different address to login.

Also, if I may ask a follow-up question, I recently had to do a Windows reset, and I noticed that my extensions icon is now missing and there doesn’t seem any way to get it back. This means I’m struggling with various things and everything is taking longer than it should. Have you any idea why this might have happened?

Thanks again for your help.

Not an issue at all! That’s what this wonderful community is here for to help other users where we can :slight_smile:

I believe things that are filled “in the clear” on webpages such as names and addresses wouldn’t be treated as needing to be as secure as passwords and card info let’s say.
I believe you may still have some identity that was saved in Chrome that is showing you the email auto-filled.

See

Under Addresses and more, you can:

Toggle Chrome’s ability to save and fill your address and contact information.
Add new address or contact information entries.
See and manage your existing address/contact information entries. Use the three vertically stacked dots next to each entry to edit or remove them.

This also shows how you can clear any other remaining saved items in your browser.

You most likely have 2FA set up correctly, when you sign in there is an option to “Remember me” which would keep your 2FA sign in session for 30 days.

You can try a few things to verify this.

  1. Try to login to the web-vault from another browser, or another device.
  2. You can clear your browser cookies and cache by selecting CTRL + Shift + Delete
    Clear cache & cookies - Computer - Google Account Help

This would be normal, you can use the same or an alternative email for your 2FA email verification method, as described in the prior link.


If you reset Windows this would have reset any settings back to your restore point, be that a week ago or when it came out of the box from the factory.
If you did a clean refresh likely any user settings would not have carried over, though some browsers do allow you to “sync” with their cloud service if you are signed in to the browser.
Often times if you have this browser sign-in enabled you can backup and automatically restore some settings in the browser such as themes and extensions.
Though Bitwarden would see this as a new login and require your master password and likely 2FA. If you didn’t have this set up, you should still be able to manually download the browser extension from your relevant browser store.

Here is a great support link with download links for browsers and a quick overview

The problem with the extensions is that the whole thing is missing! There is no icon. I cannot click it and have the extensions showing, or add to them. The entire thing is just gone :frowning:

I’ve looked at the links you suggested, but they deal with managing extensions. My problem is there aren’t any anymore.

Were you able to check the link provided to install the browser extension?

You should be able to open the Chrome web store directly.

This should allow you to search for and download any extensions from the Chrome web store as needed.
You can search for and install the Bitwarden extension there.

Alternatively the Bitwarden downloads page has links for several different browser extensions such as Firefox, Edge, and Chrome.
The Chrome extension can be accessed and downloaded directly in the chrome store with the provided link.


If you cannot see your extensions after they have been downloaded and installed via the Chrome web store, you may have them downloaded but will need to be “pinned” to show as you may be used to.
Here are a few links with some examples on how to do that. :slight_smile:

Hope this helps, and feel free to reach out if you still need further assistance.

I’ve got the extensions back again! I was convinced the entire extension setup had been obliterated somehow, probably due to me doing a Windows reset, I suppose. All it took was to select a single extension and install it and the thing reappeared. Amazing. And amazing that I could get so convinced something bad had happened :frowning: Thanks for pointing that out. I don’t think I ever would’ve thought to just add one extension just to see what happens.

I haven’t been paying much attention to the details of how Bitwarden works lately, I’m just glad it is working.
But I’ve become aware that the 2-factor login isn’t working. I’ve disabled it and re-enabled it, thinking that might nudge it into working, but it’s still failing.
I have it set to send me an email with a code number, but that just doesn’t happen. I put in my email and my password and I’m in! This isn’t right at all, it’s totally lacking the 2-factor login, even though it’s telling me it’s enabled and it is working.
Anyone know what might be causing this weird behaviour?
Any help would be much appreciated, as always.
Thank you.

Hey @kayten, did you select ‘remember me on this device’? Are you seeing this behavior in a new private window or on a different device?

Hi dwbit, there’s a tick box for “Remember email?”, but I don’t tick that because it fills in my email address automatically, which I don’t want. I did try ticking that box and it just filled in my email for me :(, and then still opened Bitwarden up without doing the 2-factor check. And this is in my browser, not in a new private window or a different device.

Hello Kayten,

If you are not being asked for your 2FA login it could very well be you selected to Remember Me during the 2FA login screen. Which I believe will not require 2FA login for 30 days.

You can try to either clear your browser cache, which should require you to verify 2FA login when using the web-vault, or also try this in a private browser.

Alternatively you can require all devices to require 2FA login again by deauthorizing all sessions, under your account settings.

1 Like