Passkey: addon not popping up

Hello,

I’ve registered a passkey for the site eduid.ch using the bitwarden addon. Registering the key was working fine, and I did a few successful tests with logging in. The bitwarden addon popped up and authenticated me using the registered key.

A few days later, I can’t log in anymore with the Passkey in Bitwarden because there is no addon popping up (for the screenshot below I manually selected and opened the item in the addon).

My setup: iOS 13.6, Firefox 119.0.1, bitwarden addon 2023.10.2

Why was Passkey-authentication working right after registration, but not after restarting the browser?

Cheers
Rolf

I am having the same issue with Chrome and Firefox andUsing ver 2023.10…2 seems to be the problem as the previous version worked ok with getting the BW popup. I had emailed support and they are checking on it.

Hi Till,
good to hear that I’m not alone :slight_smile:
Thanks for having contacted Bitwarden support.
cheers
Rolf

Rolf, I will let you know if they come up with anything.

@goll Did you check this help site? → FAQs - SWITCH edu-ID - SWITCH Help

On this site I saw an interesting link Device Support - passkeys.dev which suggests to me, that maybe at least iOS 16 would be needed.

But I can’t say whether it should work with Bitwardens browser extension independent of the used OS and browser - but maybe iOS 13.6 and Firefox, or the combination of both, at least contributes to the problem?

Rolf, Support has given me a reply. I had 2 passkeys set up, one for Amazon and one for Google. They confirmed that Amazon hasn’t yet integrated with Firefox yet. they also said that they had the same issue with Google and are working on a fix in a future update. Google didn’t work correctly in Chrome for me either, although I know it worked in ver 2023.10.0 so it is probably their latest extension update that needs some work.

BTW I am on Windows 10

Yes, I wrote that page :slight_smile:

Yes, but I’m on a mac with MacOS 13.6 which should support passkeys.

The funny thing is that sometimes the browser extension does pop up. So basically it works, but not in a stable way.

cheers
Rolf

Unfortunately for me it never worked :frowning:

I’ve found that it usually works when I reload the page using “shift-reload”. (It does not work without the “shift” key.) That’s my work-around for the moment.

(I’m using macOS 13.6.1, Firefox 120.0 and Bitwarden add-on 2023.10.2.)

I’ve just found that I can make it work on Chrome too this way. It had never worked for me on Chrome so far, I had never got the Bitwarden popup. When reloading the page with “shift-reload” on Chrome, the Bitwarden popup opens.

shift + reload (or option + reload for Safari) doesn’t work for me either :frowning:

I have a temporary fix.

System: macOS 14.2 with Firefox 120.0.1 and Bitwarden add-on 2023.12.0
In Firefox, oben “about:config”, accept the risk and search for “browser.cache.check_doc_frequency”. Set the value to 1, which corresponds to always checking for new versions of a webpage.

See: FIREFOX: How to force FireFox to reload the page and ignore cache

??? how do you did this? With FF 120 I got an error or (e.g. in google) the message, that this device don’t support passkey.

We’ve found a possible cause for our problems on the site eduid.ch.
This site initiates the passkey login on page load. It can happen that the Bitwarden scripts haven’t yet been fully injected and Bitwarden does not get the passkey authentication request. Instead, the browser handles the request itself.

We’re going to switch to a button that must be clicked to initiate the passkey login. This way, it works reliably.

1 Like