Not able to attach files in Premium on MacOS desktop

I have purchased the premium version. But can’t tell if my desktop client (macOS) has updated to premium as well. No way to tell. Nothing in the menus.

I can see attachment made in the web version on my desktop. The desktop client has no attachment button. And yes I have read the help docs where it says

To attach file from the desktop app:

  1. Open the item to attach the file to and select the Edit button.
  2. Select  Attachments.

But there is no Attachements option.

Do I have to update the client to premium? If yes, how? There is nothing in the menu.

Hi @manfred and welcome to the community :tada:

Sometimes the premium state doesn’t sync immediately, usually triggering a manual sync or logging out and back in will refresh the premium state.

Kind regards,

@djsmith85 tried that of course before I posted. Did it again now. New log in, new sync. Still no attachment button on desktop client.

Could you tell me if the desktop client should look different with premium? Where would the attachment option be in the client version.

Usually you have to enter a license key to upgrade to premium features. Couldn’t find that either in Bitwarden. A bit lost.

@manfred Okay good to know you have already tried that.

So once you select an item in the left pane and click on edit at the bottom (pen icon) or create a new item (plus sign under left pane) the the following button will show up. This button is always present regardless of premium status.

Once clicked a popup will open to upload an attachment. The popup would inform you if your premium status had not synced yet.

Another way of checking your premium status, is clicking on Account in the MainMenu and selecting Premium membership.

There’s no need to enter a license key, as the premium status is attached to your account and synced with your vault, when logging in.

I hope that helps.

Kind regards,

Thanks for coming back to me. Please see attached image. Where you can see that I don’t have the attachement option. You will see on the right that I have scrolled all the way down.

What else can be done?

Hey @manfred,

I’ve never seen this before, and I’m also not able to reproduce this (Account without premium/with premium). The button for attachments is not hidden in any state.

What version are you currently on: As you mentioned Mac, maybe via the App Store, I assume 2022.11 ?

I’d ask you to please get in touch with support via our contact page and reference this thread.

Kind regards,

Hey @manfred,

@sj-bitwarden just messaged me and she was also able to reproduce and show me the same as in your screenshot. I now know how the confusion came up.

Attachments cannot be added directly to a new item. The item needs to be saved first and then within edit-mode the attachment button shows up. The reason being that we currently do not offer uploading attachments without linking them to an existing item.

Please try and add an attachment to an existing item, and this should work. The documentation states editing an item here.

Sorry, I did not catch that earlier.

Kind regards,

thanks for coming back to me. The problem is still not solved. I re-installed the app and used an existing item but still to attachment option. I am in contact with support and hope they can resolve it.

I’m writing to confirm that the problem @manfred reports persists today in March 2023 under Bitwarden 2023.2.0 (7249) for macOS.