No 'Enter your installation ID' prompt on Windows stand alone install

I’m doing a Windows self-hosting installation. I’m following the Windows installation instructions exactly. I execute the ‘bitwarden.ps1 -install’ command. I get and answer prompts for Domain name, Let’s Encrypt, and database name. The ‘’ is successfully pulled. But then, instead of displaying the ‘Enter your installation ID’ prompt, it outputs “[?1h=” and, as I eventually realized, it waits for input. One time I was able to enter/paste the Installation ID and Key at the cursor, but every other time it locks up and doesn’t accept any type of keyboard input other than a CTRL-C which ends the script. Based on my research, it appears that the “[?1h=” output may be some type of control or escape characters that are being output to the pseudo-TTY while attempting to output the Installation ID prompt.

I will add some details and concerns regarding this issue:

  • I am attempting to install the Bitwarden self-hosting installation on a Win10Pro / Hyper-V VM with nested virtualization
  • I’m following the “Install & Deploy”{ instructions at “
  • I’m using Windows PowerShell ISE ver 7.3
  • I’ve installed Docker Desktop for Windows ver v20.10.22 as per instructions with no issues
  • I follow the instructions in the “Install Bitwarden” section
  • (3) I execute " .\bitwarden.ps1 -install" in the Bitwarden directory (Bitwarden3) (see image from original post)
  • (4) It asks and I answer the following questions:
    • Enter the domain name for your Bitwarden instance:
    • Do you want to use Let’s Encrypt to generate a free SSL certificate? (y/n):
    • Enter the database name for your Bitwarden instance:
  • It runs normally and downloads image “bitwarden/setup:2023.1.0” successfully
  • This is where the problem comes in. Instead of outputting the prompt “Enter your installation id:”, it simply outputs the following characters ([?1h=) and displays the cursor following it.
    • I found out that that appears to be TTY command defined as “DECCKM - Cursor Keys Mode, send ESC O A for cursor up
    • I believe it hangs on the following lines in run.ps1:
    • When I run docker ps, this is what I see (see image above)
    • Just one time I was able to enter a valid Installation ID and Key, and the install completed
    • I believe (but am not certain) that when it ran that one time, the dotnet text in the Command for the Setup container was not messed up as shown previously

Just as a quick note, are you running the installer within ISE or within PowerShell?

As described in

:information_source: Note
Using the Powershell ISE to run Powershell commands will cause the Bitwarden installation to fail. Completing a successful install will require Powershell.

I would also remind you that you can contact the official support team as well for more advanced issues such as this.
Or anything really for that matter, and they are always more than happy to help. :slightly_smiling_face:

I will try using just Windows PowerShell.

Thank you very much. That did the trick.

No issue, glad to hear that worked for you!