New to Bitwarden - Safari extension turned on but autofill not working at all

i have just migrated from 1Password and am quite frustrated that I can’t use Bitwarden as easily in OSX using Safari. The extension is installed. The menu item is accessible. So I am working around by searching and copying and pasting. But Bitwarden is neither recognizing a log in page or autofilling it. I can’t even click on something in the window that pops up when I click on Menu Icon - nothing happens. I have to copy and paste separately. I have tried closing and reopening Safari.

Have also followed directions for my Android phone. A window sometimes pops up, Sometimes not!

Haven’t even tried IOS on iPad!!

Hope someone can help!! :slight_smile:

Hello @Tanbaker - welcome!

Have you seen the help pages about auto-fill? They are really helpful:

Yes, I have gone through them and followed the instructions. I think perfectly.

No window pops up on a log in page, nothing happens if I right click on Log in window, Cmd + Shift + L opens a Bitwarden log in webpage.

Hi again @Tanbaker. I’m not sure why you are expecting a window to appear on a login page - Bitwarden doesn’t do that. It just fills in your credentials right into the login form.

Have a look at that link I posted above again, especially this section:

Note - for security reasons, this feature is not enabled by default, so you will have to set it up yourself. I am guessing this is the issue you are encountering. If not, can you please provide a full walk-through of what you have done, what you expect to happen, and what is actually happening so that we have some details to try to help you troubleshoot? Cheers.

Thanks for ttrying to help. I am sure it is frustrating when people don’t try to help themselves, but, I’ve been to that section. I didn’t think it applied because it is:

“experimental and opt-in”

But, taking your advice I went to “Settings → Options in your Browser Extension, select the Enable Auto-fill On Page Load option”

No such thing in Safari browser extension

“Manually Auto-fill
You can auto-fill items manually that don’t have saved URIs by opening them in the  My Vault view, and selecting the Auto-fill button.”

This didn’t work either.

![Screen Shot 2022-03-15 at 8.36.14 PM|444x500](upload://qY4V7CdEuZXyjNp1Vih93HNGwYa.jpeg

Is this not a pop up?

Nothing gets filled. Nothing happens at all using either shortcut. Nothing.

I wish I could do more to help, @Tanbaker - I am not clear what is going on at your end.

I am using Safari 15.4 on Mac OS Monterey with Bitwarden extension v. 1.56.5, and there is definitely an Enable Auto-fill On Page Load option. I am guessing it must be turned off in your settings. Keep trying - I am sure you will find it and get things working.

Hi David,

Can you check if Command + Shift + L still works for you with Safari Extension Version: 1.56.6 ?


Actually, I figured what was causing problem, I had checked following which caused the problem, unchecked both allowed me to use autofill.

a. Enable browser integration (Browser integration is used for biometrics in browser.)

b. Require verification for browser integration

1 Like

I have been to busy to trouble shoot further until now.

I am using Big Sur, Safari 15.3, Bitwarden extension v1.56.5

Trying to follow the Extension video, I don’t even get a web page that matches yours. There is no icon to click on and do I get a drop down box or whatever you want to call it which I can then fiddle with. No icons at all

I am not sure why I would be trying to do something on a webpage when I simply want the desktop app to recognize a log in page as such and then to make it possible for me to ask it to autofill or for it to automatically auto fill.

I may have to go back to 1Password.

Hi everyone and thanks for flagging the issue. We’re currently tracking it here. For now, you can use the following workaround:

This appears to occur only when the extension is unlocked through an autofill attempt (CMD+SHIFT+L); If you unlock the Safari extension the moment you open Safari, either by clicking on it or by pressing CMD+SHIFT+Y, the extension would then operate as expected and match and autofill vault items consistently.

Hi there:

As per latest support, I closed Safari and tried unlocking before I did anything else. I still just get a pop up with no autofilling!

I have followed all instructions to the extent that I can. Desktop app installed. Desktop icon in menu bar. Extension installed. Permission granted to access websites. Browser integration enabled. Bowser extension icon visible and openable (found it in another place than shown in video.)

But Safari and Bitwarden are still not communicating. If I open BW from either icon, neither recognizes that I am on a log in page. I have to search, copy and paste. (Popups do open.)

“There are no logins available to autofill for the current browser tab”