New Install - mssql restart loop

New install, ubuntu 22.04 vm on truenas core 12.

Everything is up and running, but I had to change in docker-compose.yml the location of data and log files for mssql. The default was var/opt/[logs and data] to name/rladelman771(ubuntu user) to get it to work. Every time I run the script it obvious puts the default back. Does anyone know how to change or override the default? Or can explain why this was necessary to get it to run?

My bwdata folder is in rladelman771.

Really new at cli docker. I figured out how Docker-Compose.yml volumes function, they are a mirror inside the container to outside the container. The default volume for mssql:
- …/mssql/data:/var/opt/mssql/data
- …/logs/mssql:/var/opt/mssql/log
- …/mssql/backups:/etc/bitwarden/mssql/backups

The logs and data line were preventing the mssql container from starting up. I don’t understand why it’s not working and when I entered a new folder address, the new address is empty, but the mssql starts fine. Any thoughts?

I tried to create on the host side the folders for the default locations and that did not work either even with full access chmod 777.

running ubuntu 22.04 on a VM truenas core 12 system 2 virtual cores, 2 cpu, 4 threads 4 gib memory. Everything works, but the default volume mapping for mssql.