Mysql database creation on BW unified self hosted docker


I am new to BW , I installed the latest BW unified Version in a docker container with public IP and mysql ,
starting is fine , I can reach the login site but when I try to register a new user, I get undefined Server Error.
I looks like my mysql database has no tables and no was user created.
Where to look and what can be wrong?

If you need more information, pls let me know
Thank you in advance for your help

That version is still beta. Also see Install and Deploy - Unified (Beta) | Bitwarden Help Center


“This is a beta release, which means that this deployment option may be unstable and have issues. If you manage a Bitwarden organization vault, we recommend using the officially-supported, standard deployment option.”

If you want to use BW on a regular basis, I recommend to use the regular version as explained at Install and Deploy - Linux | Bitwarden Help Center

This will use everything in Docker containers and will also provide a backup in a local folder.

Hello, sorry for the late reply, I was busy at work.
I tried in the meantime the officially-supported, standard deployment option, but I still stuck at Nginx.
I have an apache running at the server with Nextcloud, Bacularis etc. I need to figure out how to connect my existing stuff with Biwarden Docker Containers.

When you already have Apache running, this is the relevant part of the configuration I use to make Bitwarden accessible in its own domain. So just create an additional virtual host with it’s own subdomain for bitwarden and add the following options to host configuration. My server also uses Let’s Encrypt to get certifcates, so /.well-known must not be forwarded to the Bitwarden container. But otherwise it’s basically a reverse proxy including some additional headers, so Bitwarden knows where the request comes from:

ProxyPass /.well-known !
ProxyPass /
ProxyPassReverse /
ProxyPreserveHost On
RequestHeader set X-Forwarded-Proto "https"
RequestHeader set X-Forwarded-Protocol "https"
RequestHeader set X-Forwarded-Port "443"
RemoteIPHeader X-Forwarded-For
RemoteIPHeader X-Real-IP

In addition you need to make sure, that the domain settings in bwdata/env/global.override.env is correct:


Thank you so much for your help, I will try your solution this weekend and report