Mssql keeps restarting

The installation went alright, but I see mssql keeps restarting.

I found a reddit with the same problem, it said to increase resources with a link that appears dead. i can’t find any info on how to increase resources.

I’d appreciate any help with this, thanks!

Does you machine meet the minimum requirements of 2gb ram?

Yes, it has 32GB with 17GB available.

Start the instances with:

cd ./bwdata/docker
docker-compose up

That will give you more output on why it is failing to start.

Thanks. This should be helpful:

2018-05-15 15:03:30.52 Server UTC adjustment: 0:00
2018-05-15 15:03:30.52 Server © Microsoft Corporation.
2018-05-15 15:03:30.52 Server All rights reserved.
2018-05-15 15:03:30.52 Server Server process ID is 4124.
2018-05-15 15:03:30.52 Server Logging SQL Server messages in file ‘/var/opt/mssql/log/errorlog’.
2018-05-15 15:03:30.52 Server Registry startup parameters:
bitwarde -d /var/opt/mssql/data/master.mdf
bitwarde -l /var/opt/mssql/data/mastlog.ldf
bitwarde -e /var/opt/mssql/log/errorlog
2018-05-15 15:03:30.53 Server Error: 17113, Severity: 16, State: 1.
2018-05-15 15:03:30.53 Server Error 87(The parameter is incorrect.) occurred while opening file ‘/var/opt/mssql/data/master.mdf’ to obtain configuration information at startup. An invalid startup option might have caused the error. Verify your startup options, and correct or remove them if necessary.
bitwarden-mssql exited with code 1

Are you using ext4 or something else like ZFS?


I would answer with just those three letters but it won’t let me since I need 15 characters ;-).

Mssql doesn’t currently support ZFS. See here

Oke that sucks.

Do you have any idea how I can move/change 1 containers’ location?

Thanks for your help!

Actually, I may not have to move, after reading on in that thread there’s a link to this:

I’m reading now to see what I actually need to do to make that work.

You could try using a docker volume instead of the local filesystem.

We make this pretty easy to do. Just edit ./bwdata/docker/docker-compose.yml and set the comment at the top to:

# Parameter:MssqlDataDockerVolume=True

Then run ./ update.

That works perfect! I had already created new zvol with ext4 on my zfs volumes, but that didn’t help :frowning:. I’ve now changed that line to True and it starts, I was able to start it and create a new account.

Thanks a lot!

Is the wiki public? Otherwise you may want to add this to a note or something.

Edit: to be clear for others running into this, I couldn’t get the mssql-docker-zfs - Hack (github link above) to work:

  • create a zvol on zfs, format as ext4
  • make sure docker uses it as its data, set filesystem driver to overlay2
  • set the setting # Parameter:MssqlDataDockerVolume=True as stated above