Microsoft has just ruined the Yubikey experience (and syncable passkeys, too?)

Off-topic, but I have to vent…

As of the latest Windows update, two additional, completely superfluous mouse clicks are now necessary whenever using a Yubikey for FIDO2.

Anytime there is a FIDO2 request (e.g., for 2FA or passwordless login), Windows now pops up with this prompt:

image

You now have to:

  1. Click “Security key”.
  2. Click “Next”.
  3. Only then will you be prompted to touch your security key.

And who knows if this will ever get fixed…

:rage: :rage: :rage: :rage: :rage: :rage: :rage: :rage: :rage: :rage: :rage: :rage:

In case anybody else is frustrated by this, I’ve fixed it (for now) on my system by uninstalling Windows Update KB5032190.

That’s not a viable long-term solution, though. Hopefully Microsoft gets enough complaints about the new passkey prompt that they roll out a fix.

I’ve seen the same behavior on iOS and if you select use security key, it messes things up and won’t work. I’ve realized that when the window pops up now, I simply tap my key on the back of my iphone and it works fine. If you actually follow the prompts, it fails, haha.

No such shortcut in Windows, unfortunately. They key simply doesn’t accept or respond to any taps until you first click “Security key” and then click “Next”.

The other interesting aspect about the prompt is that it doesn’t offer an option to use passkeys stored in your browser extension. I haven’t started experimenting with passkeys in Bitwarden yet, but it seems to me that this Windows prompt would prevent you from using Bitwarden (or other 3rd-party) password managers to store your passkeys.

I’m surprised that I haven’t seen more complaints about this issue. Perhaps most users haven’t received the Windows update yet…