Match detection - how to make it detect my login path better?

Hi There,

I’ve been using Bitwarden for a while and something that’s been bugging me is the match detection. In our office we have a large number of virtual machines hosted in Azure and we use Bastion to connect to them. It would be great if I could get Bitwarden to detect from the which machine I was trying to connect to and put that machine at the top of the list.

I’ve been reading about match detection in the help centre.

The address for the host is very long and I can’t post a full example here but it’s something like:<tenant>/resource/subscriptions/<guid>/resourceGroups/<resource group>/providers/Microsoft.Compute/virtualMachines/<vm name>/bastionHost

Anything in angle brackets is filled by Azure, but the resulting URI is unique, so I select “EXACT” as the match, however I still have to search the vault to get the correct credential to the top of the list.

it’s a minor niggle but I am wondering if there’s a way to make it so that it detects the URI properly? aIt would mean less searching and as some of our machines are similarly named remove a slight niggle.

Hoping it’s just me missing something obvious.

ps. I have tried the default matching - no good. also the base domain is always so not an option either. The URI Is so long I don’t think I can write the regex for it.

Could you clarify this? You are saying that you have multiple vault items that use the same exact URL as shown in your example (including the substituted values between angle brackets), and you are getting successful matching on such a large number of these vault items that you now have to search through them? If so what is the difference between these vault items that share the same exact URL (i.e., what term do you search on to find the one that you want?)?

Or is the problem that when you set match detection to Exact, now you don’t get any matches, and therefore you resort to searching instead?

What is the number shown in the badge counter when you go to one of these sites?

I thought I was being clear.

The path to every machine is unique. So I set the match detection to Exact and I only have 1 set of credentials per machine.

What I want is when I get to the login page, using bastion for that machine, for the correct credentials to be at the top of the list. Instead I have to search.

The badge says 9+ (logins) available.

I’ve tried the other matching detection options. That was for completeness.

I’ll admit, I am confused by what you have said as well.

If you set the URL match to Exact, you should only ever return 1 or 0 matches. Or do you have more than one URL in each of your Bitwarden login items? (If so, the URI matching uses OR logic, so it will attempt to match any of the URLs you have entered - including items that aren’t set to use Exact matches.)

This means that you either have duplicate vault entries, or that you have multiple sets of login credentials for each machine, or that your login items for each machine contain multiple URLs.

The reason we are confused is that the Exact match detection option is supposed to solve the problem you are describing — making available only one matching login item for autofilling.

If you have multiple accounts on the same machine, then setting the match detection to Exact isn’t sufficient to allow Bitwarden to guess which of the many accounts you intend to log in to, so it makes all accounts for that machine available.

However, if you only have one set of login credentials for each machine, then there is some misconfiguration in your vault (most likely multiple URLs stored in each login item). If you delete the extraneous URLs and leave only the machine-specific URL (with Exact matching), then you should get only a single match — no list to search through.

This isn’t what I am seeing.

I have:

  1. set of credntials per machine.
  2. 1 URI per machine

If I search the vault and find the credentials (eg vmtestdb001) then, when I click on the launch icon it takes me to the login page of of the machine. I then have to find the correct login credentials and have bitwarden fill them in.

I am using Microsoft Edge, latest version, with the browser plugin.

See following for our machine vmdevapp001. I go to the login page, I have to search for the credentials, there is only one set for this machine and the BW details contain a single URI.

See the 9+ over there on the right? from the login page?
vmdevapp001 isn’t even at the top of the list.
Each of those credentials contains a single URI, which is the unique path to each machine (yes I have checked).
Each set of credentials is different. The username is the same for these ones but the passwords are all different.
The URI Is set to Exact.

Hope that’s a bit clear. My original draft included multiple screenshots but as I’m only allowed to upload a single one so I’ve had to byung them together.

@Gav Thank you for providing the additional information. A few follow-up questions:

  1. Can you confirm that when you go to Settings > Options > General in the browser extension, the Default URI Match Detection option has been set to “Exact”?
  2. In the top screenshot, I am unable to confirm that the URL in the address bar in fact starts with — can you confirm that this is the case?

In fact, I would suggest doing the following: After launching the vmdevapp001 login page, open the vault item for vmdevapp001, scroll down to the bottom and click the button labeled “Autofill and Save”.

After you have done this, click “Edit”, and inspect the second URI that has been added to the vmdevapp001 vault item. Please verify that this new URI and the originally stored URI are identical (to the last character).

Which URI is set to exact? All 9 of them MUST be set to Exact if you want to prevent them from matching all URIs on the same domain.

David, the screenshot shows that the URIs stored in the individual login items (or at least in the vmdevapp001 item for which screenshots were provided) have their match detection set to Default. This is why I asked for confirmation that the Default URI Match Detection was in fact set to “Exact”.

This is still an issue for me. I actually never found a solution and I’ve just been putting up with it since I raised the thread. Has it really been a year… yes it has.

Well, actually, it hasn’t quite been 11 months since I posted this comment in an attempt to assist you, a comment that you have yet to respond to:

If you’re still interested in finding a solution, I would suggest that you respond to the questions that are asked, and that you carry out the actions that are recommended.

P.S. In case you plan to respond to my comment from 11 months ago, please note in that time since I asked Question #1, the location of the Default URI Match Detection option has been moved to Settings > Auto-fill.

I did try these things but as they made little difference I gave up. But never mind. I’ll remember to not seek help on the forums. Thanks anyway.

Not quite understanding your reaction. How were we supposed to know what you tried or didn’t try if you never posted about it? Furthermore, my comment from December 2022 was intended to help diagnose your problem (using your responses to the three questions that I asked), and was not intended to be a solution to your problem.

FYI, if you don’t want help from the user community, you’ve always had the option to contact Customer Support.

Based on the limited information that you have provided here, this is either a case of user error (more likely), or some obscure bug triggered by a corner case (less likely). Some troubleshooting is required to determine which of these is responsible for the issue you are experiencing, but since we don’t have access to your vault or your network, your active participation and engagement with whoever is helping you will be needed to get to a resolution.

Best of luck to you!