Login with device requires app to be open on Android approving device?

I thought I had “login with device” working with the approving device being my Android phone. In particular, I configured Bitwarden to never timeout on my Android phone so that it was always unlocked. I tested this configuration and was able to get a notification from my Firefox browser extension on my phone with my phone locked. This worked exactly once.

Today I noticed that the Bitwarden app needs to be open on the Android phone or the notification won’t be received. Is that now new expected behavior? If so, it renders “login with device” cumbersome for me.

Thanks for any help.

Hello Ed,

  1. I am using Android 13/2024.5.1, and I can confirm that if BW isn’t loaded, no notification is received.
  2. If the app is loaded, even if it isn’t the foreground app, I mostly receive notifications, less if the phone is in a bedtime mode.

If your situation is 1, it isn’t working for me either. If your situation is 2 and is consistent, I would try adjusting battery optimization (and locking the app) to see if the notifications improve, if you haven’t done this already.


Hi Neuron,

I’m running “Android” 14 on a OnePlus 10 Pro.

I was experiencing your situation 1. I checked battery management for the Bitwarden app and, apparently by default, background activity is not allowed, so I switched it on and got the nag reminder that it could run down my battery. Then I closed Firefox, which logs me out of Bitwarden.

When I restarted Firefox, I followed the logon with device approach and discovered that I didn’t get the notification unless the phone was unlocked. Once I unlocked the phone via my fingerprint, I got the notification and was able to confirm the request.

I’m pretty sure I got the notification on a locked phone yesterday. Do you get the notification if your phone is locked and background processing is allowed for the BW app?


Edited to add: I more or less followed the instructions on “Don’t kill my app” and “locked” BW. Then I closed Firefox, re-opened it, and chose logon with device. The phone was locked and I got the notification. “Locking” the app must have solved the problem.

1 Like

I’ve been trying to get “login with device” working smoothly for me and I believe I’m almost there, but one issue remains.

When I issue a request to logon with device from my Firefox extension running on Windows, I don’t receive the notification on my phone if it is locked. If I unlock the phone, I get the notification immediately and can proceed to logon to the extension. I’m using a OnePlus 10 Pro running OxygenOS 14 and I’m running Bitwarden version 2024.6.0 on it…

I’ve double-checked my phone and I have enabled lock screen notifications and disabled battery optimization for the Bitwarden app. I’ve also “locked” the app to the “recently run” apps; presumably this keeps the app “open” and running in the background.

Other apps routinely send notifications to my lock screen. I think Bitwarden did it once as well, but no longer.

Thanks for any help.

I see the mods moved this post from a separate thread I created about notifications on my lock screen, evidently because I mentioned my previous issues with “login with device”, which are largely resolved.

I won’t quibble with the mods but my intention was to define a new thread. Generally, is it possible to send notifications from BW to my lock screen? There is no related notification setting in BW but I’m able to go to Android settings and allow lock screen notifications from BW.

Thanks for any help.

@Ed_LaCrosse I’m happy to move your last two comments back into a separate thread, but I don’t see how the issue is different from the original issue. Are you not still asking how you can get notified about “Login with Device” approval requests while your Android while it is locked?

The “login with device” notification from BW does not get to my phone unless it is unlocked. Is that expected behavior? That’s my primary interest at this point, and once that question is answered, I’ll go away for awhile. :slightly_smiling_face:

More generally, does the BW app generate any notifications besides the login with device notification? If so, should I expect these notifications to get to my phone if it’s locked? I ask this question because almost all of the apps on my phone that generate notifications will send them to my lock screen if I allow it. Indeed, there is the option to allow that for BW on my Android phone, so I’ve done it, but it has no apparent effect.

So, I have a question about the login with device notification specifically and a question about notifications generally. I haven’t gotten an answer the the former question in this thread so I asked the latter, more general, question in different thread.

I’ll defer to your judgment on where to put my latter question.

Thanks for any help.

I don’t think there are any other examples of push notifications generated by Bitwarden (other than “Login with Device” approval requests). However, if someone can contradict me on this, I will go ahead and break out your general question into a separate thread.

1 Like

Fair enough. Thanks for your patience.

So, my remaining question: I’m not getting the notification if my phone is locked. Is that expected app behavior?

I will refer to @Neuron5569 or other users of the Android app on that question, as I do not have personal experience with Bitwarden’s mobile apps.

1 Like

Hi Ed,

I didn’t have you check the followings, because I think it’s unlikely and I hope others would have chimed in, but maybe it wouldn’t hurt, and it would confirm your settings:

  1. On the Bitwarden icon on the home screen, press-and-hold to get a menu, click on app info. You should see that Bitwarden has “notifications” permission.
  2. When you click on Notifications, you should see that you are allowing all notifications.
  3. When you click “All notifications”, it should show the All notifications screen with configurable parameters. Mine is set to:
  • Default notification, not silent
  • Pop on screen
  • Lock screen should be set to either Show all notification content, or Show senstive content only when unlocked
  • Override Do Not Disturb

Please bear in mind that Androids can have different menus and options depending on versions and manufacturers.

If you are already checked on all of these, I am out of idea. I would post on reddit. You may get more ideas. I would, however, post the following information in addition to what you have posted here, to reduce the back-and-forths:

  • your phone and Android version
  • your BW app version
  • what you have tried to fix
  • be clearer if this is the situation where 1) your phone is locked, BW isn’t in the “recent app” list and isn’t pinned/locked on the list, OR 2) you phone is locked, BW is in the “recent app” list and it is shown to be pinned.


ps: @grb Thanks for the ping.

1 Like

Hi Neuron,

Thanks for the reply and for being patient with me.

I have gone through what I think are the equivalent notification settings on my phone (OxygenOS is different enough from stock Android to be confusing). I’ve allowed everything I can except overriding Do Not Disturb, but I may try that sometime. (None of the other apps on my phone that generate notifications on the lock screen are allowed to override Do Not Disturb).

I’ll conclude from this that the problem is not with BW, but with OnePlus. I made a quick pass through reddit and found lots of complaints about how they’ve messed up lock screen notifications recently with OS updates. But rather than waste time with that, I’ll just accept that OxygenOS doesn’t handle BW notifications properly and move on. (I’ll also never have another OnePlus phone, but that’s another subject.)

For the record in case anyone else encounters this problem, here are my details:

OnePlus 10 Pro running OxygenOS 14
BW mobile version 2024.6.0
BW in the “recent app” list and is locked to that list
Phone is locked

With above, I get no notifications from BW. If I unlock the phone with my fingerprint, I get a notification from BW immediately.

Anyway, thanks again for the effort on my behalf.

1 Like