Librewolf Extension Biometrics not working

Hello, I have bitwarden on several browsers on my MacBook and all are working perfectly: Chrome, Firefox, Waterfox, Safari…
However I cannot activate biometrics in Librewolf (firefox fork) browser.
It just continuously reports that the browser integration is not enabled despite, of course, it is!
May someone kindly help me with this?

Thanks a lot.

1 Like

I’m surprised it even works with Waterfox. Does it share the same configuration directory with regular Firefox?

For biometrics to work in the browser extension, the desktop app needs to communicate with the browser through native messaging. This requires it to place a file in the browsers directory, which in turn requires implementing support for different browsers individually.

Here is part of the code defining the directories on mac os: clients/native-messaging.main.ts at 0a73290714a0ae41fafb42bd667a3881ef7fe689 · bitwarden/clients · GitHub

 private getDarwinNMHS() {
    /* eslint-disable no-useless-escape */
    return {
      Firefox: `${this.homedir()}/Library/Application\ Support/Mozilla/`,
      Chrome: `${this.homedir()}/Library/Application\ Support/Google/Chrome/`,
      "Chrome Beta": `${this.homedir()}/Library/Application\ Support/Google/Chrome\ Beta/`,
      "Chrome Dev": `${this.homedir()}/Library/Application\ Support/Google/Chrome\ Dev/`,
      "Chrome Canary": `${this.homedir()}/Library/Application\ Support/Google/Chrome\ Canary/`,
      Chromium: `${this.homedir()}/Library/Application\ Support/Chromium/`,
      "Microsoft Edge": `${this.homedir()}/Library/Application\ Support/Microsoft\ Edge/`,
      "Microsoft Edge Beta": `${this.homedir()}/Library/Application\ Support/Microsoft\ Edge\ Beta/`,
      "Microsoft Edge Dev": `${this.homedir()}/Library/Application\ Support/Microsoft\ Edge\ Dev/`,
      "Microsoft Edge Canary": `${this.homedir()}/Library/Application\ Support/Microsoft\ Edge\ Canary/`,
      Vivaldi: `${this.homedir()}/Library/Application\ Support/Vivaldi/`,
    /* eslint-enable no-useless-escape */

I’m not familiar with librefox in particular, but I believe this would require changes to the code to add support for librefox (by adding the correct directory for it).

1 Like

Thanks, this was actually helpful.
I’m quite sure that while Waterfox shares the same directoy configuration as Firefox, Librewolf does not.
In fact I can find the “NativeMessagingHosts” folder in the Chrome, Edge and Mozilla folders.
So I suppose that Waterfox shares the Mozilla folder with Firefox while LibreWolf doesn’t.
I’ll wait to see if someone has a solution for this :slight_smile:
Unfortunately I’m not familiar with coding

Well, I undertand it is quite ironic to reply myself however I found the solution through the LibreWolf documentation.
To enable Native Messaging in LibreWolf it is needed to run a command in the terminal:

ln -s ~/Library/Application\ Support/Mozilla/NativeMessagingHosts ~/Library/Application\ Support/LibreWolf/NativeMessagingHosts

This is needed to add a symbolic link to the NativeMessagingHosts folder.

Now Biometrics works as a charm! :heart_eyes: