Issue while importing a "Family Sharing" license into an on-premise installation

Dear all,

I am running my own installation of bitwarden and I wanted to start sharing with my wife some passwords (not all :P)
I therefore followed the tutorial from https://help.bitwarden.com/article/licensing-on-premise/ #Organization Account (Sharing)

I downloaded the license key from the bitwarden.com account and each time i try to upload it into my on-premise installation, I’m receiving the following issue:

Errors have occurred
Invalid license. Make sure your license allows for on-premise hosting of organizations and that the installation id matches your current installation.

I noticed in the code on github at /core/blob/master/src/Core/Models/Business/OrganizationLicense.cs

public bool CanUse(GlobalSettings globalSettings)
{
if(!Enabled || Issued > DateTime.UtcNow || Expires < DateTime.UtcNow)
{
return false;
}

       if(Version >= 1 && Version <= 4)
       {
           return InstallationId == globalSettings.Installation.Id && SelfHost;
       }
       else
       {
           throw new NotSupportedException($"Version {Version} is not supported.");
       }

}

and in the license JSON I downloaded, the value for “SelfHost”: false

Any idea how to enable SelfHost from a bitwarden generated license ?

Tx
Sylvain

and in the license JSON I downloaded, the value for “SelfHost”: false

Do you have an organization plan that allows self hosting?

Actually I thought that downloading the license (as indicated in the doc) would be obvious and would allow the organisation to be self hosted
I was wrong

How to you proceed to create such a plan?

Thx for your reply !

I believe you’ll need the “Enterprise” package. This is generally used for business purpose and supports on-premise hosting. If you already have an account head over to settings and then under the Organizations section, select “Create an Organization.” This will then give you the option to select the Enterprise package. Please see https://help.bitwarden.com/article/licensing-on-premise/ for help. :slight_smile:

Dear Eliot

It is exactly what I’m trying to do (the link you shared is the one I initially mentionned)

I set-up a Family Organisation, which is supposely supporting the on-premise hosting, generated & downloaded the license, mentioning my installation ID and tried to import it to my on-premise installation
which is failing …

What is going wrong ?

Sylvain

I know it sounds basic but have you tried going through the on-premise installation again? From other forums I’ve heard that the installation can sometimes be corrupt.

Also could you please confirm the version you are running. Looks like there was an issue with the family org which was fixed in version 1.14.1: https://github.com/bitwarden/core/issues/127

Ok

I think I found out my issue … i used the Free sharing version (we are only 2 on my plateform) and it certainly does not provide on-premise hosting for this type of organisation

So is this indeed the case . Is it not possible to install a 2 person organisation free license in an on-premise deployment?

BTW do you need to create the exact same account on the bitwarden site (email + master password) as you are using on the on-prem installation, or can it be different and will the license still work?

Dear Seren

This is correct: a family (2 persons free license) cannot be used on a on-premise deployment.
it can only be used on the bitwarden cloud instance

no need to create the same accounts on bitwarden site.
you will just need to create an organisation, select the license type and once the license is valid, you will need to download it by specifying your “on-premise installation key” which will allow you to install it on your on-premise installation

actually, on the license type, it is not written explicitly that a license is not working on “on-premise installation” but it is written on the license type supporting it :slight_smile:

1 Like