iPhone app refuses to work

This works great on my home computer, but trying to get it to work on my iPhone is frustrating and, so far, impossible. I end up having to go back and forth between the app and wherever I am logging into and copy and paste. Despite the toolbar popping up at the bottom, and showing me the relevant details, if I tap it, nothing happens and no forms are filled. If I have multiple logins for a page, it won’t allow me to choose a different one from the one it shows. Which doesn’t matter anyway because, as said, it won’t even fill that one in.
This has been going on over multiple updates in both the app and iOS, so I can’t believe other people are having this issue. Any tips on resolving it for me?


I would start by double-checking that you have enabled auto-fill passwords in your iOS settings and that you have selected Bitwarden as the default method. Hard to be sure, but it sounds like your iOS security settings aren’t quite right.

1 Like

Yup, that’s what I’ve got.

OK, great. Now if you deselect Bitwarden and allow filling from Keychain instead, does it work? That should isolate whether it is the Bitwarden app misbehaving or iOS.

Just spent the last ten minutes trying to figure out how to set up Keychain. lol But I got it, and it filled in the password perfectly.

If that’s the case, then I suggest you contact Bitwarden support to see if they can help you troubleshoot the issue - that is definitely unexpected behaviour.

To be certain, I would probably recommend that OP first switch the iOS autofill setting back to Bitwarden (and deselecting Keychain), to see if the problem still exists. Perhaps in the process of getting Keychain set up to work, some problem got cleared…

Switched back to Bitwarden and turned off Keychain and it’s the same problem. As per the suggestion, I have contacted Support.


@Steven_Beeder , did you manage to solve this issue?

@RunningBeare I rarely use it on iPhone, but the last time I did, maybe a month ago, it was still doing this.

@StickBoy, Mine works on iOS 17 on iPhone and iPad so I am curious to find out what is different, that it is not working for you. From the web page linked by dh024 I am using the ‘keyboard’ method, other settings as discussed above with Bitwarden selected for auto-fill and as the default for new TOTP. Does that all accord with your case?

I’m having the exact same issue as described by Stickboy. I’m on an iPhone 15 Pro with IOS 17.3.1
I was using lastpass without issues for years switched to BW recently.

I’ve checked (attached screenshots) -
IOS settings auto-fill passwords is enabled and Bitwarden is the default method
I’ve also activated the app extension in the bitwarden autofill settings

When I go to a site or apps login page and click on the username and password it pops up asking if I want to use the details found in Bitwarden but when I click/press the option nothing happens

Workaround: toggle between the bitwarden app and the destination app or site and copy and paste manually which is slow and frustrating.

I’ve tried to research this online there are suggestions that it could be linked to memory limitations and encryption alogorithms (KDF & Argon2id) but don’t want to mess around with those without more certainty that that’s the solution to this issue and clear advise on what to change to.


I am travelling shortly so may not get back on it for a little. According to the Bitwarden page linked, you should receive a warning of any memory issues. I am guessing that with a current phone you would have difficulty running into such issues, or it would be obvious to you that you are loading up activities on your phone.

So, your problem arises when fill does not occur on tapping the password, after Bitwarden recognises the screen and pops up an option. We have the same phone and iOS versions so comparable tracing may be possible (if a little boring in detail :slight_smile: )

Hi, ok that’s good, yar ok to wait.

Yes that describes what’s happening :+1:

Hi @RunningBeare, sorry about the delay. I was a bit busy when I got back so deferred looking into it.

Having trawled through the settings and your comments above, I can think of only a couple of things that look as though they might be relevant. The principal one is, do you have Javascript enabled in Settings…Safari…Advanced ? The behviour you describe in your opening post is exactly what I see if I turn it off.

I am running 24.2.0, by the way. I had to update manually from the App store when it came up, which was a bit surprising. Other settings I have within Bitwarden do not seem likely to affect things given you have dealt with Auto-fill.

Hi Mulled, I’ve just checked my settings and javascript is enabled. That said and this maybe a coincidence but my problems seem to have gone away. I’ve tried to replicate on both my phone and my wife’s who was also having issues but can’t. At the weekend I signed up to a paid plan to set up an organisation so that might have something to do with it :man_shrugging: the good news from my side is that it’s gone away :tada:

A good result is a good result. :slight_smile: