Inviting another user to an organisation - no mail is sent

Tried again the next day, and it worked immediatly. Seems that it was a temporary problem.

Dear community members,

I’ve been using the free version of Bitwarden now for some weeks and now I tried to set up an “organisation” to share some passwords with my wife on her PC. She also got a Bitwarden account.

So I defined an “organisation” in my account. Then I click on “Organisations” in the menu and the “Members”, where my own account is listed. Clicking on “Invite a member” (I use the German version) I enter the mail address of my wife, and click on “invite”. In the members list her entry is marked now as “invited”.

Well, I would expect now, that she would get an invitation mail with a link to accept it, and would have access to the entries inside the “organisation”.

But… Nothing happens. No mail. I waited for hours, I clicked on “re-send invitation”… Nothing. And of course we have checked the spam folders.

So do we misunderstand something? Is something not working properly? Any idea?

Regards from Germany,

Hey there, can you please double check to make sure the email is correct, and if still not working at that time (check spam folder) connect with the official support team (link above if on desktop, or via Bitwarden website).

I am on a paid subscription
I have sent invitation both to addresses on my private mail domain and to gmail account.
Invitations are not received.
Just tried to resend them today, but nothing.