Intermittent login failures (inconsistent behavior)

I have had Bitwarden for over a year and now it doesn’t recognize my email and/or password, even though I have double-checked my password written down elsewhere. After many tries it will let me sometimes with the very same info provided in previous tries. What is this all about? Is this to make me delete my old account and start anew? I can’t find my other passwords without having another place to keep them in written form.

Hello @limandri and welcome to the community forums,

Strange that as you mentioned attempting to login with your username/password combination gives you an error, but occasionally does allow you to login successfully. I have not personally run into this issue (other than genuinely using the wrong password for the wrong account, work/personal, or just fat-fingering it.)

I am curious if you have noticed this issue across multiple devices, do you use the mobile apps or browser extension to login to your Bitwarden vault?
You may also try to login directly to

If you are having issues but still able to login to your vault, I would highly recommend making an unencrypted backup using the .JSON file option, and save this in a secure location. This way you will have a recent backup of your data as needed.

1 Like

Hi @limandri - welcome!

In addition to the great advice that Kent has provided above, I would add a couple of things:

First, if you are seeing intermittent issues logging in, then you are most certainly doing something inconsistently. It is not Bitwarden behaving inconsistently. Here are some of the things that often cause a password to fail, even if are “certain” you are typing it correctly:

  • missing a capital letter
  • mistyping a punctuation character (e.g., ’ instead of `)
  • mistyping a character (e.g., 0 instead of O)
  • using international characters and/or an international keyboard
  • using the correct password but mistyping your email address at login

Second, the only way to confirm that Bitwarden is behaving inconsistently is to type out your password in a text editor (no need to save it), and copy and paste it into your login, perhaps modifying it slightly each time until it works. Once you have it working, keep pasting it in over and over at each login, and you will see that it always behaves the same way (unless you change keyboard layouts, change machines, etc.).

I suggest that on your next successful login, change your master password to something that will be easy to enter, has no international characters, but will still be secure (i.e., un-guessable and at least 14 characters), as well as backing up your Bitwarden vault, as Kent mentioned above. I hope you figure out your issue.

I’m having a somewhat similar issue and didn’t want to start a duplicate topic. I received an email that my paid account would renew soon. I knew that I needed to update the card I had previously used to pay for BW.

When I went to and attempted to login, it did not accept my login PW or master PW. Tried on multiple browsers and multiple devices. I also logged out of the browser extension on one device and wouldn’t let me log back in there either. Now I am getting the “Slow down, too many recent attempts” error. I had originally created my PW in KeePassXC when I was trying out BW, so I don’t have any of the PW issues referenced by @dh024. I also have the PW saved in BW and it comes up as identical to the one I have saved in KP.

Unlike the OP, I have not had a successful login yet since this occurred. Any ideas? Thanks in advance.

Hi @tenkaravt - welcome! And thanks for sharing your experience. That sounds frustrating.

To me, it sounds like you can be certain that you are using the correct password. Are you certain that it is the EXACT same email, as well? I have made that mistake in the past. It can even be something as simple as [email protected] vs [email protected]. I know that Gmail treats those as equivalent, but Bitwarden will not.

Thanks. Yes, I am sure it is the same email. I used the master PW reset and I received the email telling me that feature is not enabled for my account. So BW knows my account exists but won’t allow me to login.

I’m also unsure how long to wait before attempting to try again. I don’t know what “Wait a short time” means according to BW.

Okay. This is bizarre. I just tried again - with the same email/PW combo and it let me in. One problem is that the screen requesting my 2FA wasn’t showing up after entering the above. Now it worked fine on multiple browsers. That was very odd.

When you say this, I presume you have 2FA enabled for your Bitwarden login (As is HIGHLY recommended :slight_smile:)
Were you not being prompted for 2FA when entering your login information correctly as you said?
When able to successfully login with those credentials you were then prompted to authenticate with your 2nd factor authentication method as expected in the multiple browsers?

One thing I would double check when entering the Master Password, you can toggle the visibility of your password by clicking the “eye” icon next to the password field, which should look like this → 👁
This way you can be sure the proper information expected to be entered is working to login, and there are not any incidental spaces or other characters.

Yes, very good point, @cksapp - a leading or trailing space is easy to insert when copying and pasting. And they are essentially invisible, so the credentials appear correct.

I am hoping this is the case, which in turn would be a nice and easy fix. :slight_smile:
We are all human and can tend to overlook the smallest things that can in turn cause a world of headache, I know I have had my fair share of head scratchers that ended up making me feel like an absolute dunce for not catching.

I can’t wait for the day machines are perfect :laughing: and we have absolutely no login issues and breaches. Until that time I’ll just have to keep on using Bitwarden.

1 Like

Thanks for the replies. Yes, @cksapp I definitely have 2FA enabled. You are correct, I was not being prompted for 2FA when entering my info correctly. Yes, once it finally authenticated on Firefox, it then finally authenticated on Brave, the desktop app, and my phone.

Thanks for the tip, but yes, I did check for both leading and trailing spaces. One reason I quit using a competing password manager was that was a frequent issue when copying and pasting, long, complex passwords. That forced me to get into the habit of frequently checking for those.

I’m not sure what happened here. I double and triple checked everything. After about 90 minutes of trying, it just finally worked. Personally, I don’t believe in random things popping up and just spontaneously disappearing and working again. Obviously, there was either an infrequently seen bug or a human error on my part. Considering I’ve never had the problem before, I would lean more towards the latter being the issue this time. Regardless, thanks for the help.

Haha… as long as they are built by humans, we all know that will never happen. Besides, do you really believe there is something such as perfect code? I suspect not. Even with the AI driven coding, such as DeepMind (and others) that is being developed, I am skeptical that will ever happen. But, that’s just me.

i have the same issue. Since yesterday, my self hosted bitwarden just stop working with chrome extension and desktop app. It keeps working on my phone.
I have been typing my login and password for years. Now it returns “username or password is incorrect”.
It can’t be my credentials because i can connect on my bitwarden if i go directly on url. Not working only through chrome extension and windows app

If you are running a version of a Bitwarden server that is about a year old or older, it is now deprecated and must be updated. The latest BW clients will not work. See here for details:

I recently added additional firewall blocking for all ports and ip addresses outside of the US, now my bitwarden login to the web vault using device verification won’t work. I have to move my phone off my network and it works fine. I also noticed I could not get to the unless I specifically add there IP Address (for cloudflare to my table as allowed. Any ideas why this might be an issue?

If you’re wanting to block your network from accessing countries external to the US, it may be better for you to use the self-hosted version of Bitwarden instead

CDNs such as Cloudflare are global so firewalls can block their IPs even if the IP is registered in the US. for example is registered in both US and Canada according to and

Depending on your use case you may have gotten the firewall rules the wrong way around. Inbound geo-blocking is more common than outbound is, but there are use cases for it :slight_smile:

Definitely not the problem

@textendo Welcome to the forum!

If you are experiencing some kind of login problem, I would suggest starting your own topic by going to the Ask the Community forum and clicking the “New Topic” button (in the upper right corner of the page):

Please provide as much information as possible about your system and about the problem you are encountering.

Same issue. Been using for two years. Cannot access anymore and yes my password and username are correct. Has been a kitchen sink of errors but wrong username/ password is the current.

@Scot777 See my advice to @textendo above — start your own topic.

Unless the problem is intermittent (i.e., you are sometimes able to log in, and other times not able), then your problem is not the “same issue” reported in this thread. Even if your login problems are intermittent, any type of temporary server glitch that might cause such behavior is unlikely to be related to the problem that OP experienced a year ago.