Installation of docker image fails due to permission problems

Hi,

I have problems installing bitwarden on premise because of file permission problems
during the setup.

Host ist centos 7.4. Setup is running as root (tried different users)

Here is the output of bitwarden.sh install:

[email protected] bw]# sh bitwarden.sh install
 _     _ _                         _            
| |__ (_) |___      ____ _ _ __ __| | ___ _ __  
| '_ \| | __\ \ /\ / / _` | '__/ _` |/ _ \ '_ \ 
| |_) | | |_ \ V  V / (_| | | | (_| |  __/ | | |
|_.__/|_|\__| \_/\_/ \__,_|_|  \__,_|\___|_| |_|

Open source password management solutions
Copyright 2015-2018, 8bit Solutions LLC
.....

===================================================

Docker version 1.13.1, build 94f4240/1.13.1
docker-compose version 1.9.0, build 2585387

(!) Enter the domain name for your Bitwarden instance (ex. bitwarden.company.com): bw.harlan.de

(!) Do you want to use Let's Encrypt to generate a free SSL certificate? (y/n): n

Trying to pull repository docker.io/bitwarden/setup ... 
1.20.0: Pulling from docker.io/bitwarden/setup
Digest: sha256:42c20f5c5aaf2ab90619ba41a100c7ac258ab412d439cbbf43185d573eadd35c
Status: Downloaded newer image for docker.io/bitwarden/setup:1.20.0
mkdir: cannot create directory '/bitwarden/docker': Permission denied
mkdir: cannot create directory '/bitwarden/ssl': Permission denied
mkdir: cannot create directory '/bitwarden/letsencrypt': Permission denied
mkdir: cannot create directory '/bitwarden/identity': Permission denied
mkdir: cannot create directory '/bitwarden/nginx': Permission denied
chown: changing ownership of '/bitwarden/scripts/run.sh': Permission denied
chown: changing ownership of '/bitwarden/scripts': Permission denied
chown: changing ownership of '/bitwarden/env/uid.env': Permission denied
chown: changing ownership of '/bitwarden/env': Permission denied
chown: changing ownership of '/bitwarden': Permission denied

Can anybody help?

M.H.

Docker version 1.13.1, build 94f4240/1.13.1
docker-compose version 1.9.0, build 2585387

You are using old versions of docker and compose. Update and try again.

You can find instructions on how to get the latest docker version for CentOS here : https://docs.docker.com/install/linux/docker-ce/centos/

Thank you. That helped!

I had to install versions from github.docker.com and to remove
centos standard versions.