Inline autofill not showing up on Android 13

I’m in the middle of switching from one unrooted Pixel 4a running Android 13 (cracked screen) to another unrooted Pixel 4a running Android 13 (new condition). I made sure all my Bitwarden settings were exactly the same as they are on the old phone. They both have all the accessibility options mentioned on the FAQ page enabled, and the new phone even as all battery saver modes disabled as mentioned on the Troubleshooting Autofill page. I also tried enabling Draw-Over on both phones, and it worked fine on the cracked one no matter what password fields I tapped, but again, absolutely nothing when i tap any password field on the new one. Am I missing something? It there a secret extra setting in android that didn’t carry over in the device swap process? I’ve made sure the vault is set not to lock at all while i’m trying to just get it working and still nothing.

If you’ve followed the steps outined in the Android Troubleshooting Guide Troubleshooting Android Auto-fill | Bitwarden Help & Support and that doesn’t resolve the issue, you can reach out support team directly at Get in Touch | Bitwarden

I had the same issue but it can be fixed by disabling google auto fill from google account settings.