Import from Dashlane (.csv)

Hi, I am new on bitwarden, coming from Lastpass and Dashlane.
I tried to import my lastpass csv. and it is easy and ok but I would like to import my Dashlane vault because it is the most uptodate. I have got an issue with that : there is no json file proposed on the Dashlane website. Only a readable .csv and the Bitwarden site does not accept it. Any help ? Thanks !

Try this:

1 Like

Thanks, Peter. That’s what I have done but I think the article must be updated as Dashlane do not propose anymore the json format. (Unless, I am mistaken ?)
Capture d’écran 2021-08-23 à 14.25.50
And when I do the export in .csv, the Bitwarden website does not accept it.

In that case compare the csv of Dashlane with what Bitwarden wants to have and then adjust your database:

You’re right. I’m going to do that since there is no automatic function. Thanks for your help !

Couple of things to try. If your dashlane csv/json has some insanely long passwords etc, bitwarden might fail to import. Edit those out, obviously always keep a clean copy, try importing again. If it’s not taking it, it’s going to be something like that. Or you said you had lastpass as well, possibly import to lastpass and export it back out with lastpass and try to import, that’s if it happens to be some weird anomalous thing preventing bitwarden from parsing the dashlane data.

Also…sometimes there can be isuses, at least what I have seen, with bitwarden and some browsers/pop-ups. For example, I kept trying to export my bitwarden data through Vivaldi with the bitwarden extension. No matter what I did, it just did nothing. No error, no indication, no immediate logs until finally I saw it was . Finally I clicked the pop out arrow and it worked fine. I understand this may not be you, but it’s just a reminder that the browse, browser settings, extensions and/or things might be the culprit.

Hello, thanks for answering. The issue was that I was not in BIg sur and so unable to get the json from dashlane without this update. My daughter did it for me on her machine and I have then been able to import the json. The last issue is I’ve got now duplicated entries. Have to clean this mess…