Import error saying that a password exceeds 1000 chars but all my passwords are 12 chars max


I followed the tutorial here to import passwords from Lastpass but I keep getting this error:


All my passwords are 12 characters max and there isn’t a single line in the csv that exceeds 1000 chars.

Does someone have an idea on how to fix this?


I have the same problem, but my message says the value exceeds 10,000 characters, which is impossible. I am importing from 1Password and getting about 4 of the error messages. Support told me this:

“It wasn’t your password, it is the Notes. We’ve seen cases where the Notes are filled with a software license agreement. Could you please open the file using a spreadsheet editor? Check whether your data is inside the file.”

But I still cannot find any notes which are so long like that, so still looking for a solution. Until then, can’t import anything which makes BitWarden impossible to use with my 800 passwords I need imported.

1 Like

Thank you for your answer, I think I created what Lastpass calls “secure notes” indeed. I’ll try to remove those and reupload the csv file.

Ok it works now. I had to open the file in MS Excel end manually remove all the lines starting with http://sn (I figured out that these were the one corresponding to the “secured notes” mentioned earlier). I also removed a few items that had a long text in the “extra” column.

Are you importing via .CSV? Although not as pretty .JSON it has the advantage that people can spot patterns. You will probably find something that way.

I wrote a little Python script to automate the fixing of the original Lastpass csv if anyone’s interested. It creates another csv file where text longer than 512 chars in the “password” and “extra” columns are replaced with the following message: “Unavailable. Go to your Lastpass vault to find that info”.

It’s available here: GitHub - Lay3r8/bitwarden_lastpass_unoffender at master

1 Like

It’s from 1Password, so the file is a .1pif file. I tried exporting as .csv, but on import, I get an error message, “an error has occurred. Nothing has been imported”.

Also, if BitWarden can’t import some selected items, why doesn’t it still import what it can and identify what was not imported? That would make this so much easier.

The limit is on encrypted data. It means that the encrypted password exceeds 1000 characters. How long the encrypted password is correlates vaguely with how long the factual password is.

So I found a fix. It seems there are problems with the export from 1Password and how it works with BitWarden, so instead, I exported from 1P and then imported into LastPass, then exported from LastPass and used that data to import into BitWarden. That worked perfectly. I had to import the text into the text field of the import to get it to work, but I got there.

Just FYI, if your longest password is 12 characters, you might seriously want to consider increasing the length of your passwords.

The maximum entropy provided by 12 characters is typically below the current threshold for brute force attacks (depending on the size of the character set allowed), and in the future that will only get easier.

1 Like

I thought I had fixed the problem by exporting my 1Password data into LastPass and then into Bitwarden (bit longwinded, but…) however now I find that some of my logins are missing, and it seems random. Missing random logins means I can’t move from 1Password, so I am back at square one. How can I import my 1Password data? I am on a Mac.

@tgreer & team, it would be great to hear from you on the subject of a robust migration path from 1Password to Bitwarden. Is it a priority for Bitwarden and/or will it ever be a priority? Tin_Robot (above) and others have highlighted the current experience. It would be great to hear your assessment and whether a more robust and comprehensive path is ever likely?
Thank you.

We’re adding better import info/error messages. Not just for 1P, but overall :+1:

1 Like

It is better, but it still makes no sense as it is identifying logins which are just simple normal logins like a Gmail account. I posted separately about that, but why is it flagging it for having 10,000 characters when it clearly does not. Last Pass has no trouble importing it.