HTTP Basic authentication does not show pop-up

As stated in the subject, I’ve a page that asks for HTTP basic authentication, but when the Bitwarden’s extension is enabled in Chrome it doesn’t show up, and instead shows:
401 Authorization Required

I’m running latest versions of Chrome and Bitwarden on Windows 10.

I tried disabling auto-fill in Bitwarden but nothing changed, the only thing that makes the authentication work is when I disable the extension.

BTW, I tried using Incognito with only Bitwarden extension and the same issue.

Expected Result
To show this pop-up:

Actual Result
Shows this instead:

Here’s my nginx code:

                location /REDACTED {
                        satisfy any;
                        auth_basic 'Authenticated users only';
                        auth_basic_user_file "REDACTED";
                        auth_request /auth;
                        proxy_pass http://REDACTED;
                location = /auth {
                        root /var/www;
                        include fastcgi_params;
                        fastcgi_pass unix:/run/php/php7.4-fpm.sock;
                        fastcgi_index index.php;
                        fastcgi_param  SCRIPT_FILENAME  /var/www/auth.php; #$fastcgi_script_name;

Please advise.

@mmagdy Welcome to the forum!

How many login items do you have that will match to that page?

Bitwarden only has partial support for Basic Auth, and it works best if you have a single login saved for the site. From the documentation:

If a single login item is present for a matching URI, the credentials will be autofilled in the background and no authentication prompt will be shown.

Note that the pop-up being suppressed is expected behavior.

There are 4 items that match this URI.

So, you are saying that if I have 1 item it will work properly? I will try and let you know.