Howto install new Yubikey, self hosted


I just got my Yukikeys and want to install them on my selfhosted instance.
I have edited /global.override.env and entered the 2 values I received from Yubico API key signup

I have rebooted but I don’t think this is enough to accept the new variables (is there a docker command to do this?) because when I try to register the Yubikey at the 2FA setting on my bitwarden web site

I get
ScreenShot 2023-01-27 at 14.11.36

What is missing?

Hi there,
I’m using multiple Yubikey but I don’t remember that I had to register my Yubikey in the config (but maybe I forgot that I did).

Anyway, do you have imported your license file from account to your self hosted instance?

If everything above is done, go in the directory where is your ./ script and send these commands:
./ rebuild
./ restart

Without the rebuild command, it will just not apply the new conf.


license file is imported, otherwise I wouldn’t have a running registered instance.
I’ve run the 2 commands and then tried again registering the key but I still get the same error…

I reset the key to factory, generated new OTP, registered on the above site again, entered the new values in global.override.env, rebuild the docker.
And now it has worked.