How to set the Google Authenticator?

Hello to all,

I need some help with setting the Bitwarden 2fa authentication with Google Authenticator.

I have installed Google Authenticator and set it up,but when I try to login on Edge’s Bitwarden extension on Windows it doesn’t ask me for the Google Authenticator code.

Please help me to resolve these problems.

Thanks to all in advance.

Generally, you should make a separate thread for each unrelated question/request.

For 2FA authentication:

  1. Log in the the Web Vault.

  2. Click on the account profile icon in the upper right corner, and select “Account Settings”.

  3. In the left-hand navigation menu, click “Security”.

  4. Click on the “Two-step login” tab (Arrow 1 in the screenshot below) and then click on the first Manage button (Arrow 2 in the screenshot):

  5. Enter your master password at the prompt, after which you will see a QR code, as well as a random 32-digit alphanumeric code (in uppercase red letters) just below the QR code.

  6. Scan the QR code using Google Authenticator, or copy and paste the red 32-digit alphanumeric code into the authenticator, and complete the setup in Google Authenticator.

  7. When Google Authenticator shows you a 6-digit TOTP code, enter that code below the QR code that still being displayed in the Bitwarden Web Vault, in the field labeled “3. Enter the resulting 6 digit verification code from the app”, and click Turn on, then click Close.

  8. In the Web Vault, click View recovery code in the “Warning” section at the top of the page, then enter your master password and click “Continue”. Print and/or copy this code, and store it somewhere safe (e.g., as part of your Emergency Sheet).

1 Like

Thank you for replying.

I’ve already done that,but when I try to login in Microsoft Edge Bitwarden extension, it doesn’t ask me for the TOTP code,it only asks me for the master password.

1 Like

It should ask for the master password first, and then for the 2FA.

If entering the master password logs you in to the browser extension without requiring 2FA, then do the following:

  1. Log in to the the Web Vault.

  2. Click on the account profile icon in the upper right corner, and select “Account Settings”.

  3. Scroll down to the section titled “Danger Zone”, and click on “Deauthorize Sessions”.

  4. In the pop-up window, enter your master password and click “Deauthorize Sessions”.

  5. Log back in on all of your apps. When entering the 2FA code in each app, do not check the option labeled “Remember me”.


I did everything you told me, but the Google Authenticator app doesn’t have such an option like ‘Remember me’.

What should I do next?

The “Remember me” option is part of the Bitwarden authentication process. In any case, it’s disabled by default, so if you don’t see it, you don’t have to worry about it. If you do see this option, don’t enable it.

What happens when you log in to your Edge browser extension now? Does it ask for a TOTP code?

No,it doesn’t ask for the TOTP code.

Does it log you in?

Yes,it logs me in.

Please post a screenshot showing the “Providers” section of the “Two-Step Login” tab from the Security section of your Account Settings in the Web Vault (the same screen that I had posted above).

In addition, please post a screenshot of the username input screen from the login form for your Edge browser extension, the way it looks just before you click the Continue button. Before uploading this screenshot, please use an image editor to erase or obscure your email address.

Finally, please let me know whether any of your apps (e.g., browser extensions on other browsers, Desktop apps, mobile apps, or CLI) do ask you for a TOTP code when you log in, and if so, which ones.

When I try to login via Bitwarden app on Android it asks me for the TOTP code, when I try to login on Bitwarden Vault on Windows/Android it is the same.

If I try to login on Edge’s Bitwarden extension on Windows it also asks me for the TOTP code.

But if I don’t log out from the extension and close the browser and then reopen it again ,it asks only for the master password,not for the TOTP code.

That’s all.

Now the question is how do I set it to log out automatically on exiting the Edge browser on Windows?

OK, the issue that is confusing you is that when you close your browser and re-open it, it does not log out of your Bitwarden account (hence no request to log back in with 2FA), it only locks your vault.

If you want your Bitwarden browser extension to actually log out when you close the browser, then go to Settings and set the “Vault Timeout Action” to “Log out”.

1 Like

It works now! Thank you so much!